Unexpected relationship is identified between Device Manager and the Local Area Connections

Article translations Article translations
Article ID: 823206 - View products that this article applies to.
Expand all | Collapse all

Symptoms

When you install Microsoft Windows (any version) or Microsoft Windows Server (any version) on a system that has two identical network adapters installed, the association between the network adapters that are identified in Device Manager and the Local Area or Ethernet Connections that are identified in Network Connections may be reversed. For example, network adapter number 1 may be associated with Local Area Connection 2 (Ethernet 2 in later editions) and network adapter number 2 may be associated with Local Area Connection (Ethernet in later editions).

Note This issue does not occur with the computers that have Consistent Device Naming (CDN) enabled in BIOS.

Cause

During Windows Server installation, hardware detection is performed during the initial portion of Setup. The order in which devices are detected is not guaranteed, and the order can change to optimize any platform or for any other reason that affects the timing.  Since connection names get assigned to adapter names in the order they appear in the OS, the connection name to adapter name mapping may be modified from boot to boot.

Workaround

To work around this problem, rename the Local Area Connections that are listed in Network Connections.

In Windows 8 (Windows Server 2012) and later editions of Windows and Windows Server, the computer manufacturer has the opportunity to identify the NICs in a vendor-specific naming scheme through the BIOS.  If this feature, known as Consistent Device Naming, is installed, the variable name mapping won’t occur.

Properties

Article ID: 823206 - Last Review: August 20, 2014 - Revision: 7.0
Applies to
  • Windows Server 2012 R2 Essentials
  • Windows Server 2012 R2 Datacenter
  • Windows Server 2012 R2 Foundation
  • Windows Server 2012 R2 Standard
  • Windows 8.1 Enterprise
  • Windows 8.1 Pro
  • Windows 8.1
  • Windows Server 2012 Datacenter
  • Windows Server 2012 Essentials
  • Windows Server 2012 Foundation
  • Windows Server 2012 Standard
  • Windows 8 Enterprise
  • Windows 8 Pro
  • Windows 8
  • Windows Server 2008 R2 Service Pack 1
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Standard
  • Windows 7 Service Pack 1
  • Windows 7 Ultimate
  • Windows 7 Enterprise
  • Windows 7 Home Premium
  • Windows 7 Home Basic
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows Server 2008 Standard
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Starter
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows XP Service Pack 3
Keywords: 
kbprb KB823206

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com