Objektänderungen oder neue Objekte möglicherweise verloren, wenn das ADAM-Synchronizer-Tool in Windows Server 2003 synchronisiert die Daten aus Active Directory zu ADAM

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Artikel-ID: 947498 - Produkte anzeigen, auf die sich dieser Artikel bezieht
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Problembeschreibung

Synchronisieren von Daten aus dem Verzeichnisdienst Active Directory zu ADAM, verwenden Sie das Tool Active Directory-Anwendungsmodus (ADAM) Synchronizer (Adamsync) in Windows Server 2003. Anschließend können einige Objektänderungen oder neue Objekte ohne Warnung verloren.

Dieses Problem kann unerwartetes Verhalten für Ihre Anwendungen führen. Angenommen, kann eine Anwendung ADAM zum Authentifizieren von Benutzern verwendet, die Benutzerauthentifizierung fehlschlagen. Außerdem können in Abfragen (Lightweight Directory Access Protocol) falsche Ergebnisse zurückgegeben werden.

Ursache

Das Tool ADAM Synchronizer verwaltet einen Stapel für LDAP-Abfragen und Abfrageergebnisse. In manchen Fällen können die Ergebnisse verzahnt sein. In einigen Szenarien dazwischenliegende möglicherweise das Tool ADAM Synchronizer nicht vorzeitig suchen. Einige Attribute sind deshalb nicht synchronisiert.

Beispielsweise beim Synchronisieren von Gruppen würde es im Hintergrund die Mitglieder löschen werden (Wenn die Anzahl der Mitglieder mehr als 5000) ohne die Admin, dessen bewusst.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Der Hotfix ist jedoch nur das Problem zu beheben, das in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systeme an, bei die dieses spezielle Problem auftritt. Dieser Hotfix wird möglicherweise zusätzliche Tests angezeigt. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft, für das nächste Update warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, ist ein Abschnitt "Hotfix Download verfügbar" am Anfang dieses Knowledge Base-Artikels. Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an Microsoft Customer Service und Support, um den Hotfix zu erhalten.

Hinweis:Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Normale Servicegebühren werden jedoch für weitere Fragen und Problemen, die für diesen bestimmten Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf der folgenden Microsoft-Website:
http://support.Microsoft.com/contactus/?ws=Support
Hinweis:Das Formular "Hotfix Download verfügbar" zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen:

Um diesen Hotfix anwenden zu können, benötigen Sie Windows Server 2003 Service Pack 1 oder Windows Server 2003 Service Pack 2 auf dem Computer installiert.Klicken Sie für Weitere Informationen auf die folgende KB-Artikelnummer:
889100So erhalten Sie das neueste Servicepack für Windows Server 2003

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Updates besitzt die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) aufgeführt. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln, verwenden dieDie ZeitzoneRegisterkarte derDatum und UhrzeitElement in der Systemsteuerung.
Windows Server 2003 mit Service Pack 1, x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Adamsync.exe1.1.3790.3071210,94414-Jan 200809: 27X 86
Windows Server 2003 mit Service Pack 2, x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Adamsync.exe1.1.3790.4218210,94414-Jan 200809: 51X 86
Windows Server 2003 mit Service Pack 1, x 64-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Adamsync.exe1.1.3790.3071363,52014-Jan 200812: 23X 64
Windows Server 2003 mit Service Pack 2, x 64-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Adamsync.exe1.1.3790.4218363,52014-Jan 200812: 30 UhrX 64

Status

Microsoft hat bestätigt, dass es sich um ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt "Beziehen sich auf" aufgeführt sind.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates klicken Sie auf die folgende KB-Artikelnummer:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 947498 - Geändert am: Samstag, 17. Januar 2015 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
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Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 947498
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