You cannot run a report in Microsoft Dynamics CRM 4.0

Překlady článku Překlady článku
ID článku: 946753 - Produkty, které se vztahují k tomuto článku.
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Limited Microsoft Dynamics content is provided on the Microsoft Knowledge Base public website. For complete content and additional resources on Microsoft Dynamics, please visit:

Dynamics Customers
Microsoft Dynamics CustomerSource*
Dynamics Partners
Microsoft Dynamics PartnerSource

* Requires customers have a Microsoft Dynamics service plan like the Business Ready Enhancement Plan, or Software Assurance.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

You cannot run a report in Microsoft Dynamics CRM 4.0. This problem occurs if the following conditions are true:
  • You run Microsoft Dynamics CRM 4.0 on a server that is running Microsoft Windows Small Business Server 2003 R2 (Windows SBS).

    Note Windows SBS 2003 R2 contains Microsoft SQL Server 2005 Workgroup Edition.
  • You use an Internet-Facing Deployment (IFD) of Microsoft Dynamics CRM 4.0.

Příčina

This problem occurs because the Microsoft Dynamics CRM Connector for SQL Server Reporting Services is required to run a report when you use an IFD of Microsoft Dynamics CRM 4.0. However, SQL Server 2005 Workgroup Edition does not support custom data extensions. Therefore, the Microsoft Dynamics CRM Connector for SQL Server Reporting Services does not work against SQL Server 2005 Workgroup Edition. If you use an IFD of Microsoft Dynamics CRM 4.0, you cannot access the report.

Řešení

To resolve this problem, upgrade SQL Server 2005 Workgroup Edition to one of the following editions:
  • SQL Server 2005 Standard Edition
  • SQL Server 2005 Enterprise Edition

Další informace

When you use a local intranet, you can configure Kerberos authentication and configure trust for delegation. The Microsoft Dynamics CRM Connector for SQL Server Reporting Services is not required when you use a local intranet.

The Report Scheduling Wizard does not work when you use SQL Server 2005 Workgroup Edition because SQL Server 2005 Workgroup Edition does not support snapshots.

Microsoft Dynamics CRM 4.0 only supports SQL Server 2005 Workgroup Edition when SQL Server 2005 Workgroup Edition is used together with Windows SBS 2003 R2.

For more information about Microsoft Dynamics CRM 4.0 IFD setup scenarios, visit the following Microsoft Web site:
http://download.microsoft.com/download/8/f/e/8fe2d0e8-62a5-4d7e-b041-5e49a7194ae2/Microsoft Dynamics CRM 4 IFD Setup Scenarios.docx
Poznámka: Toto je článek určený k rychlému zveřejnění, který vydala přímo služba podpory společnosti Microsoft. Uvedené informace jsou poskytovány jako odpověď na vzniklé problémy. Vzhledem k požadavku na rychlé zveřejnění je možné, že zpráva obsahuje typografické chyby, a může být kdykoli bez ohlášení revidována. Další pokyny naleznete v dokumentu Podmínky užití.

Vlastnosti

ID článku: 946753 - Poslední aktualizace: 16. ledna 2015 - Revize: 1.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Dynamics CRM 4.0
Klíčová slova: 
kbnosurvey kbarchive kbmbsreports kbexpertiseadvanced kbtshoot kbprb kbexpertisebeginner kbmbsmigrate kbexpertiseinter KB946753

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com