Informazioni su alcuni tipi di file bloccati dopo l'installazione di Office 2003 Service Pack 3

Traduzione articoli Traduzione articoli
Identificativo articolo: 938810 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

Questo articolo contiene informazioni su alcuni tipi di file bloccati dopo l'installazione di Microsoft Office 2003 Service Pack 3 (SP3).

INTRODUZIONE

Questo articolo contiene informazioni dettagliate sui tipi di file bloccati da Office 2003 SP3 e sulle modalità per abilitare questi tipi.

Informazioni

Tipi di file bloccati

Dopo avere installato Office 2003 SP3, i seguenti tipi di file di Microsoft Office Excel 2003, Microsoft Office PowerPoint 2003 e Microsoft Office Word 2003 risultano bloccati. Per impostazione predefinita, questi tipi di file vengono bloccati in quanto il codice di analisi utilizzato da Office 2003 per aprirli e salvarli è meno sicuro. Pertanto, l'apertura e il salvataggio di questi tipi di file potrebbero costituire un rischio.

Nella seguente tabella sono riportati i nomi dei valori del Registro di sistema e i tipi di file corrispondenti di cui, per impostazione predefinita, viene impedita l'apertura.
Riduci questa tabellaEspandi questa tabella
Nome del valore del Registro di sistemaTipi di file bloccati
CDRCorel Draw (cdr)
LotusandQuattroFiles.wk1, wk4, wj3, wk1 FMT, wks, wk3, wk3 FM3, wj2, wq1, fm3, wj1
LegacyBinaryFilesGrafici di Microsoft Excel 4.0 (xlc)
LegacyDatabaseAndDatasourceFilesDBF 2 (dBASE II) (dbf)
FilesBeforePowerPoint97Questo criterio impedirà l'apertura di file precedenti a PowerPoint 97 e con tipi di file quali ppt, pot, pps e ppa. Si noti che questa caratteristica non è applicabile a Microsoft PowePoint 97.
FilesBeforeVersionViene impedita l'apertura di tutti i file di Word il cui numero di versione è inferiore ma non uguale a Word 6.0 per Windows. Sono incluse le seguenti versioni di file:
  • Word 1.x per Windows
  • Word 4.x per Macintosh
  • Word 1.2 per Windows (Giappone)
  • Word 1.2 per Windows (Corea)
  • Word 5.x per Macintosh
  • Word 1.2 per Windows (Taiwan)
  • Word 2.x per Windows
  • Word 2.x per Windows (lingue bidirezionali)
  • Word 2.x per Windows (Giappone)
  • Word 2.x per Windows (Corea)
  • Word 2.x per Windows (Taiwan)
È possibile aumentare o ridurre il numero di versione predefinito. Per ulteriori informazioni sulle versioni, scorrere il presente articolo per visualizzare l'elenco.
Nella seguente tabella sono riportati i nomi dei valori del Registro di sistema e i tipi di file corrispondenti di cui, per impostazione predefinita, viene impedito il salvataggio.
Riduci questa tabellaEspandi questa tabella
Nomi dei valori del Registro di sistemaTipi di file bloccati
FilesBeforePowerPoint97Questo criterio impedisce il salvataggio dei tipi di file precedenti a PowerPoint 97 e con tipi di file quali ppt, pot, pps e ppa. Si noti che questa caratteristica non è applicabile a Microsoft PowePoint 97.
LotusandQuattroFiles.wk1, wk4, wj3, wk1 FMT, wks, wk3, wk3 FM3, wj2, wq1, fm3, wj1
LegacyBinaryFilesGrafici di Microsoft Excel 4.0 (xlc)
LegacyDatabaseAndDatasourceFilesDBF 2 (dBASE II) (dbf)

Attivazione dei tipi di file bloccati

Importante Questa procedura può aumentare i rischi per la protezione. L'esecuzione di questa procedura potrebbe rendere il computer o la rete più vulnerabile agli attacchi di utenti malintenzionati o programmi software dannosi, quali i virus. Si consiglia di attenersi alla procedura descritta nel presente articolo per attivare i programmi perché funzionino secondo lo scopo per cui sono stati progettati o per implementare specifiche funzionalità delle applicazioni. Prima di apportare tali modifiche, si consiglia di valutare i rischi derivanti dall'implementazione di questo processo in un ambiente particolare. Se si decide di implementare questo processo, adottare ogni ulteriore procedura che faciliti la protezione del sistema. Si consiglia di utilizzare la presente procedura solo se è effettivamente necessaria.

Per attivare i tipi di file bloccati, utilizzare uno dei metodi seguenti.

Metodo 1: Utilizzo di un aggiornamento scaricabile per riattivare automaticamente tutti i tipi di file

Microsoft ha creato un insieme di aggiornamenti per riattivare tutti i tipi di file. Per installare gli aggiornamenti, attenersi alla seguente procedura.

Per ulteriori informazioni sul download dei file di supporto Microsoft, fare clic sul numero dell'articolo della Microsoft Knowledge Base:
119591 Come ottenere file di supporto Microsoft dai servizi online
Il file è stato controllato e non contiene virus. Microsoft ha utilizzato il software antivirus più recente disponibile al momento della data di pubblicazione del file. Il file viene salvato su server con un livello di protezione avanzata che impedisce modifiche non autorizzate.
  1. Scaricare i file appropriati dall'Area download Microsoft. A questo fine, fare clic su uno o più dei collegamenti seguenti:
  2. Fare doppio clic sul file salvato nel passaggio 1.
  3. Scegliere per confermare l'installazione del file.
  4. Se un'applicazione di Office è in esecuzione, riavviarla.
Dopo avere installato l'aggiornamento, le impostazioni del Registro di sistema vengono aggiornate per consentire l'apertura e il salvataggio di tutti i tipi di file supportati da Microsoft Office 2003. Tali tipi di file includono quelli bloccati per impostazione predefinita in Office 2003 SP3. Il codice di analisi utilizzato per aprire e salvare questi tipi di file è meno sicuro. È consigliabile installare questi aggiornamenti solo se occorre lavorare regolarmente con questi tipi di file.

Microsoft ha inoltre creato un insieme di aggiornamenti che consentono il ripristino delle impostazioni del Registro di sistema configurate da Office 2003 SP3. Per installare gli aggiornamenti, attenersi alla seguente procedura:
  1. Scaricare i file appropriati dall'Area download Microsoft. A questo fine, fare clic su uno o più dei collegamenti seguenti:
  2. Fare doppio clic sul file salvato nel passaggio 1.
  3. Scegliere per confermare l'installazione del file.
  4. Se un'applicazione di Office è in esecuzione, riavviarla.
Nota Dopo l'installazione dell'aggiornamento, le impostazioni del Registro di sistema vengono aggiornate a quelle configurate da Office 2003 SP3. Inoltre non è più possibile aprire o salvare i tipi di file bloccati per impostazione predefinita in Office 2003 SP3.

Metodo 2: Utilizzo dei modelli amministrativi per impostare le chiavi del Registro di sistema

Per impostare queste chiavi del Registro di sistema, è possibile utilizzare i modelli amministrativi contenuti nell'aggiornamento dei modelli amministrativi (ADM), dei file OPA e del testo esplicativo per Office 2003 Service Pack 3.

Per scaricare questo aggiornamento, visitare il seguente sito Web Microsoft (informazioni in lingua inglese):
http://www.microsoft.com/downloads/details.aspx?familyid=BA8BC720-EDC2-479B-B115-5ABB70B3F490

Metodo 3: Impostazione manuale dei valori del Registro di sistema

Per attivare questi tipi di file nei vari prodotti, è possibile impostare manualmente i valori del Registro di sistema. A questo scopo, attenersi alla procedura appropriata per il prodotto in uso.

Importante In questa sezione, metodo o attività viene illustrato come modificare il Registro di sistema. L'errata modifica del Registro di sistema può causare seri problemi. Attenersi quindi scrupolosamente alla procedura indicata. Per maggiore protezione, eseguire una copia di backup del Registro di sistema prima di modificarlo. In questo modo sarà possibile effettuarne il ripristino in caso di problemi. Per ulteriori informazioni su come eseguire il backup del Registro di sistema e su come ripristinarlo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322756 HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows XP


Nota È consigliabile sbloccare temporaneamente i tipi di file. Dopo avere aperto o salvato i file, bloccare nuovamente i tipi di file.

Excel


Per consentire a Excel 2003 di aprire i tipi di file precedenti di Excel, attenersi alla procedura seguente:
  1. Uscire da Excel 2003.
  2. Fare clic sul pulsante Start, scegliere Esegui, digitare regedit nella casella Apri, quindi scegliere OK.
  3. Individuare e selezionare la seguente sottochiave del Registro di sistema:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Excel\Security
  4. Dopo avere selezionato la sottochiave specificata al passaggio 3, scegliere Nuovo dal menu Modifica, quindi scegliere Chiave.
  5. Digitare FileOpenBlock, quindi premere INVIO.
  6. Con la sottochiave FileOpenBlock selezionata, scegliere Nuovo dal menu Modifica, quindi scegliere Valore DWORD.
  7. Digitare LotusandQuattroFiles, quindi premere INVIO.
  8. Fare clic con il pulsante destro del mouse su LotusandQuattroFiles e scegliere Modifica.
  9. Nella casella Dati valore digitare 0, quindi scegliere OK.
  10. Ripetere i passaggi da 6 a 9 per le voci del Registro di sistema LegacyBinaryFiles e LegacyDatabaseAndDatasourceFiles.
  11. Scegliere Esci dal menu File per chiudere l'editor del Registro di sistema.
Per consentire a Excel 2003 di salvare i tipi di file precedenti di Excel, attenersi alla procedura seguente:
  1. Uscire da Excel 2003.
  2. Fare clic sul pulsante Start, scegliere Esegui, digitare regedit nella casella Apri, quindi scegliere OK.
  3. Individuare e selezionare la seguente sottochiave del Registro di sistema:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Excel\Security
  4. Dopo avere selezionato la sottochiave specificata al passaggio 3, scegliere Nuovo dal menu Modifica, quindi scegliere Chiave.
  5. Digitare FileSaveBlock, quindi premere INVIO.
  6. Con la sottochiave FileSaveBlock selezionata, scegliere Nuovo dal menu Modifica, quindi scegliere Valore DWORD.
  7. Digitare LotusandQuattroFiles, quindi premere INVIO.
  8. Fare clic con il pulsante destro del mouse su LotusandQuattroFiles e scegliere Modifica.
  9. Nella casella Dati valore digitare 0, quindi scegliere OK.
  10. Ripetere i passaggi da 6 a 9 per le voci del Registro di sistema LegacyBinaryFiles e LegacyDatabaseAndDatasourceFiles.
  11. Scegliere Esci dal menu File per chiudere l'editor del Registro di sistema.
PowerPoint


Per consentire a PowerPoint 2003 di aprire i tipi di file precedenti di PowerPoint, attenersi alla procedura seguente:
  1. Uscire da PowerPoint 2003.
  2. Fare clic sul pulsante Start, scegliere Esegui, digitare regedit nella casella Apri, quindi scegliere OK.
  3. Individuare e selezionare la seguente sottochiave del Registro di sistema:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\PowerPoint\Security
  4. Dopo avere selezionato la sottochiave specificata al passaggio 3, scegliere Nuovo dal menu Modifica, quindi scegliere Chiave.
  5. Digitare FileOpenBlock, quindi premere INVIO.
  6. Con la sottochiave FileOpenBlock selezionata, scegliere Nuovo dal menu Modifica, quindi scegliere Valore DWORD.
  7. Digitare FilesBeforePowerPoint97, quindi premere INVIO.
  8. Fare clic con il pulsante destro del mouse su FilesBeforePowerPoint97 e scegliere Modifica dal menu di scelta rapida.
  9. Nella casella Dati valore digitare 0, quindi scegliere OK.
  10. Scegliere Esci dal menu File per chiudere l'editor del Registro di sistema.
Per consentire a PowerPoint 2003 di salvare i tipi di file precedenti di PowerPoint, attenersi alla procedura seguente:
  1. Uscire da PowerPoint 2003.
  2. Fare clic sul pulsante Start, scegliere Esegui, digitare regedit nella casella Apri, quindi scegliere OK.
  3. Individuare e selezionare la seguente sottochiave del Registro di sistema:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\PowerPoint\Security
  4. Dopo avere selezionato la sottochiave specificata al passaggio 3, scegliere Nuovo dal menu Modifica, quindi scegliere Chiave.
  5. Digitare FileSaveBlock, quindi premere INVIO.
  6. Con la sottochiave FileSaveBlock selezionata, scegliere Nuovo dal menu Modifica, quindi scegliere Valore DWORD.
  7. Digitare FilesBeforePowerPoint97, quindi premere INVIO.
  8. Fare clic con il pulsante destro del mouse su FilesBeforePowerPoint97 e scegliere Modifica dal menu di scelta rapida.
  9. Nella casella Dati valore digitare 0, quindi scegliere OK.
  10. Scegliere Esci dal menu File per chiudere l'editor del Registro di sistema.
Word


Per consentire a Word 2003 di aprire i tipi di file precedenti di Word, attenersi alla procedura seguente:
  1. Uscire da Word 2003.
  2. Fare clic sul pulsante Start, scegliere Esegui, digitare regedit nella casella Apri, quindi scegliere OK.
  3. Individuare e selezionare la seguente sottochiave del Registro di sistema:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Security
  4. Dopo avere selezionato la sottochiave specificata al passaggio 3, scegliere Nuovo dal menu Modifica, quindi scegliere Chiave.
  5. Digitare FileOpenBlock, quindi premere INVIO.
  6. Con la sottochiave FileOpenBlock selezionata, scegliere Nuovo dal menu Modifica, quindi scegliere Valore DWORD.
  7. Digitare FilesBeforeVersion, quindi premere INVIO.
  8. Fare clic con il pulsante destro del mouse su FilesBeforeVersion, quindi su Modifica.
  9. Nella casella Dati valore digitare il valore corrispondente a uno dei valori visualizzati nella , quindi scegliere OK.

    Ad esempio, il valore predefinito di questa voce è impostato su "Word 6.0 per Windows", ossia "101". Viene pertanto impedita l'apertura di tutti i file di Word il cui numero di versione è inferiore ma non uguale a Word 6.0 per Windows. È possibile aumentare o ridurre la versione predefinita. Le versioni specificate nella tabella delle versioni dei file di Word sono in ordine crescente.

    Nota Se si imposta il valore della voce su 0, possono essere aperti tutti i file delle versioni precedenti. È consigliabile impostare il valore di questa voce su uno dei valori indicati nella tabella delle versioni dei file di Word anziché su 0, in quanto il codice di analisi utilizzato per aprire i tipi di file precedenti è meno sicuro.
  10. Scegliere Esci dal menu File per chiudere l'editor del Registro di sistema.
Tabella delle versioni dei file di Word
Riduci questa tabellaEspandi questa tabella
VersioneValore del Registro di sistema
Word 1.x per Windows33
Word 4.x per Macintosh33
Word 1.2 per Windows (Giappone)34
Word 1.2 per Windows (Corea)35
Word 5.x per Macintosh35
Word 1.2 per Windows (Taiwan)36
Word 2.x per Windows45
Word 2.x per Windows (lingue bidirezionali)46
Word 2.x per Windows (Giappone)46
Word 2.x per Windows (Corea)47
Word 2.x per Windows (Taiwan)48
Word 6.0 per Windows101 (impostazione predefinita).
Word 6.0 per Macintosh104
Word 95 RTM104
Word 95 Beta105
Word 97 per Windows193
Word 98 per Macintosh193
Word 2001 per Macintosh195
Word X per Macintosh195
Word 9 per Windows217
Word 10 per Windows257
Word 11 per Windows268
Word 2004 per Macintosh268
Word 11 salvato da Word 12274
Disattiva il blocco di tutti i file0

Corel Draw


Per consentire l'apertura di file con estensione cdr, attenersi alla seguente procedura:
  1. Chiudere tutte le applicazioni di Office 2003.
  2. Fare clic sul pulsante Start, scegliere Esegui, digitare regedit nella casella Apri, quindi scegliere OK.
  3. Individuare e selezionare la seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools\Graphics Filters\Import
  4. Dopo avere selezionato la sottochiave specificata al passaggio 3, scegliere Nuovo dal menu Modifica, quindi scegliere Chiave.
  5. Digitare CDR, quindi premere INVIO.
  6. Con la sottochiave CDR selezionata, scegliere Nuovo dal menu Modifica, quindi scegliere Valore DWORD.
  7. Digitare Enabled, quindi premere INVIO.
  8. Fare clic con il pulsante destro del mouse su Enabled e scegliere Modifica.
  9. Nella casella Dati valore digitare 1, quindi scegliere OK.
  10. Scegliere Esci dal menu File per chiudere l'editor del Registro di sistema.

Ulteriori informazioni

Per ulteriori informazioni sui tipi di file bloccati, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
922847 Visualizzazione di un messaggio di errore quando si tenta di aprire un tipo di file bloccato dalle impostazioni dei criteri del Registro di sistema in PowerPoint 2007 o in PowerPoint 2003
922848 Visualizzazione di un messaggio di errore quando si tenta di aprire un tipo di file bloccato dalle impostazioni dei criteri del Registro di sistema in Excel 2007 o in Excel 2003
922849 Visualizzazione di un messaggio di errore quando si tenta di aprire un tipo di file bloccato dalle impostazioni dei criteri del Registro di sistema in Word 2007 o in Word 2003
922850 Visualizzazione di un messaggio di errore quando si tenta di aprire o salvare un tipo di file bloccato dalle impostazioni dei criteri del Registro di sistema in uno dei programmi Office 2007 o Office 2003
I prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilità di tali prodotti.

Proprietà

Identificativo articolo: 938810 - Ultima modifica: martedì 22 aprile 2008 - Revisione: 5.2
Le informazioni in questo articolo si applicano a
  • Microsoft Office 2003 Service Pack 3
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Word 2003
Chiavi: 
kbtshoot kberrmsg kbexpertisebeginner kbprb KB938810
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com