คุณไม่สามารถเข้าถึง SMB ที่ใช้ร่วมกันบนเครือข่ายขององค์กรผ่านการเชื่อมต่อบริการการเข้าถึงระยะไกล (RAS) จากคอมพิวเตอร์ที่ใช้ Windows Vista

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 933468 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณสร้างการเชื่อมต่อบริการการเข้าถึงระยะไกล (RAS) ไปยังเครือข่ายขององค์กรจากคอมพิวเตอร์ที่ใช้ Windows Vista คุณไม่สามารถเข้าถึงการบล็อกข้อความเซิร์ฟเวอร์ (SMB) ที่ใช้ร่วมกัน อย่างไรก็ตาม ถ้าคุณใช้การPing:คำสั่งเพื่อทดสอบการเชื่อมต่ออินเทอร์เน็ต การทดสอบ ping จะสำเร็จ

สาเหตุ

ปัญหานี้เกิดขึ้นหากเงื่อนไขใด ๆ ต่อไปนี้เป็นจริง:
  • มีกรอง TCP พอร์ต 139 บนเครือข่ายขององค์กร
  • netbios ผ่าน TCP/IP (NetBT) ถูกปิดการใช้งานบนไคลเอนต์ระยะไกลของ Windows Vista

การแก้ไข

ข้อมูล Service Pack

เมื่อต้องการแก้ไขปัญหานี้ ให้ขอรับ Service Pack ล่าสุดสำหรับ Windows Vista สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
935791วิธีการขอรับ Service Pack ของ Windows Vista รุ่นล่าสุด

ข้อมูลโปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนที่ได้รับการสนับสนุนจาก Microsoft พร้อมใช้งานแล้ว อย่างไรก็ตาม โปรแกรมแก้ไขด่วนนี้มีเป้าหมายเพื่อการแก้ไขปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น นำโปรแกรมแก้ไขด่วนนี้ไปใช้กับระบบที่พบปัญหานี้เท่านั้น โปรแกรมแก้ไขด่วนนี้อาจได้รับการทดสอบเพิ่มเติม ดังนั้น หากคุณไม่ได้รับความเสียหายรุนแรงจากปัญหานี้ เราขอแนะนำให้คุณรอการปรับปรุงซอฟต์แวร์ถัดไปที่มีโปรแกรมแก้ไขด่วนนี้

หากมีโปรแกรมแก้ไขด่วนพร้อมสำหรับการดาวน์โหลด คุณจะเห็นส่วน "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" อยู่ที่ด้านบนของบทความฐานความรู้นี้ หากส่วนนี้ไม่ปรากฏขึ้น โปรดติดต่อฝ่ายบริการสนับสนุนลูกค้าของ Microsoft เพื่อขอรับโปรแกรมแก้ไขด่วน

หมายเหตุ:หากเกิดปัญหาอื่น ๆ หรือ ถ้ามีการแก้ไขปัญหาเป็นสิ่งจำเป็น คุณอาจต้องสร้างการร้องขอบริการแยกต่างหาก ค่าใช้จ่ายในการสนับสนุนปกติจะเกิดขึ้นเมื่อมีคำถามและประเด็นการสนับสนุนอื่นๆ ซึ่งไม่จัดอยู่ในโปรแกรมแก้ไขด่วนเฉพาะที่กล่าวถึงนี้ สำหรับรายการของหมายเลขโทรศัพท์ของฝ่ายบริการและการสนับสนุนลูกค้าของ Microsoft ทั้งหมด หรือถ้าต้องการสร้างคำขอรับการสนับสนุนแยกต่างหาก โปรดเข้าสู่เว็บไซต์ของ Microsoft ต่อไปนี้::
http://support.microsoft.com/contactus/?ws=support
หมายเหตุ:แบบฟอร์ม "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" แสดงภาษาในโปรแกรมแก้ไขด่วนมีอยู่ หากคุณไม่เห็นภาษาของคุณ เป็นเพราะไม่มีโปรแกรมแก้ไขด่วนสำหรับภาษานั้น

ข้อกำหนดเบื้องต้น

คุณสามารถติดตั้งโปรแกรมแก้ไขด่วนนี้ได้ทันที

ข้อกำหนดในการเริ่มต้นระบบคอมพิวเตอร์ใหม่

คุณต้องเริ่มระบบของคอมพิวเตอร์ใหม่หลังจากใช้โปรแกรมแก้ไขด่วนนี้

ข้อมูลการทดแทนโปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนนี้ไม่ได้แทนฮอตฟิกซ์อื่น ๆ

ข้อมูลรีจิสทรี

ถ้าต้องการใช้โปรแกรมแก้ไขด่วนในแพ็คเกจนี้ คุณไม่จำเป็นต้องแก้ไขรีจิสทรี

ข้อมูลแฟ้ม

โปรแกรมแก้ไขด่วนรุ่นภาษาอังกฤษนี้มีแอตทริบิวต์แฟ้ม (หรือแอตทริบิวต์แฟ้มหลังจากนี้) ซึ่งแสดงในตารางต่อไปนี้ วันที่และเวลาของแฟ้มเหล่านี้จะปรากฏในรูปแบบเวลามาตรฐานสากล (UTC) เมื่อคุณดูข้อมูลแฟ้ม ข้อมูลจะถูกแปลงเป็นเวลาท้องถิ่น เมื่อต้องการค้นหาความแตกต่างระหว่างเวลา UTC กับเวลาท้องถิ่น ใช้โซนเวลาแท็บในรายการวันและเวลาใน'แผงควบคุม'
Windows Vista รุ่นที่ใช้ x86
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดแฟ้มวันที่เวลาแพลทฟอร์ม
Rasmans.dll6.0.6000.20549237,05603 2007 มีนาคม02:51x86
windows Vista รุ่น 64 บิต
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดแฟ้มวันที่เวลาแพลทฟอร์ม
Rasmans.dll6.0.6000.20549281,60003 2007 มีนาคม04:00x64

การหลีกเลี่ยงปัญหา

สิ่งสำคัญนี้ส่วน วิธี หรืองานประกอบด้วยขั้นตอนที่บอกวิธีการแก้ไขรีจิสทรี อย่างไรก็ตาม ปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีไม่ถูกต้อง ดังนั้น โปรดตรวจสอบให้แน่ใจว่าคุณได้ทำตามขั้นตอนเหล่านี้อย่างระมัดระวัง สำหรับการป้องกันเพิ่มเติม ให้สำรองรีจิสทรีก่อนทำการปรับเปลี่ยน เพื่อที่คุณจะสามารถคืนค่ารีจิสทรีได้หากมีปัญหาเกิดขึ้น สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสำรองข้อมูลและคืนค่ารีจิสทรี โปรดคลิกที่หมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
322756วิธีการสำรองข้อมูลและคืนค่ารีจิสทรีใน Windows


เมื่อต้องการแก้ไขปัญหานี้เป็นการชั่วคราว ให้ดำเนินการตามขั้นตอนต่อไปนี้:
  1. คลิกเริ่มการทำงาน
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    เริ่มการทำงานของปุ่ม
    ประเภท:regeditในการเริ่มการค้นหากล่อง แล้วคลิกregedit.exeในการโปรแกรมรายการ
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    โล่ห์'การรักษาความปลอดภัย'
    ถ้าคุณได้รับการพร้อมท์ สำหรับรหัสผ่านของผู้ดูแลระบบ หรือ สำหรับการยืนยัน พิมพ์รหัสผ่านของคุณ หรือคลิกดำเนินการต่อ.
  2. ค้นหาและคลิกที่คีย์ย่อยของรีจิสทรีต่อไปนี้::
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
  3. ในการแฟ้ม:เมนู คลิกส่งออก.
  4. ในการบันทึกกล่อง ระบุตำแหน่งที่ตั้งที่คุณต้องการบันทึกแฟ้ม
  5. ในการชื่อแฟ้มกล่อง ป้อนชื่อของแฟ้ม
  6. ในการบันทึกเป็นชนิดกล่อง คลิกแฟ้มรีจิสทรี.
  7. ในการช่วงการส่งออกกล่อง คลิกเลือกสาขาแล้ว คลิกบันทึก.
  8. ค้นหาและคลิกที่คีย์ย่อยของรีจิสทรีต่อไปนี้::
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
  9. คลิกขวาในบานหน้าต่างรายละเอียด การผูกรายการรีจิสทรีในการชื่อ:คอลัมน์ คลิกปรับเปลี่ยนแล้ว คัดลอกข้อมูลในนั้นข้อมูลค่า:กล่องไปยังคลิปบอร์ด
  10. ค้นหาและคลิกที่คีย์ย่อยของรีจิสทรีต่อไปนี้::
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\smb\Linkage
  11. คลิกขวาในบานหน้าต่างรายละเอียด การผูกรายการในการชื่อ:คอลัมน์ คลิกปรับเปลี่ยนวางข้อมูลจากคลิปบอร์ดไปข้อมูลค่า:กล่องข้อความ การแทนที่ข้อมูลต้นฉบับ แล้ว คลิกตกลง.
  12. ออกจากตัวแก้ไขรีจิสทรี และรีสตาร์ทคอมพิวเตอร์

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "การใช้งาน" ปัญหานี้ถูกแก้ไขใน Windows Vista Service Pack 1 ครั้งแรก

ข้อมูลเพิ่มเติม

ปัญหานี้ไม่ได้เกิดขึ้นเมื่อคุณใช้คอมพิวเตอร์ที่ใช้ Microsoft Windows XP เป็นไคลเอนต์ระยะไกล คอมพิวเตอร์ที่ใช้ Windows Vista ต้อง NetBT ให้เปิดใช้งานกับการเชื่อมต่อผ่านพอร์ต 139 สำหรับ SMB ในการผูกกับอะแดปเตอร์ RAS อย่างถูกต้องสำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
824684คำอธิบายของคำศัพท์มาตรฐานที่ใช้เพื่ออธิบายปรับปรุงซอฟต์แวร์ของ Microsoft
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

คุณสมบัติ

หมายเลขบทความ (Article ID): 933468 - รีวิวครั้งสุดท้าย: 20 ตุลาคม 2553 - Revision: 2.0
ใช้กับ
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Ultimate
Keywords: 
kbautohotfix kbvistasp1fix kbPubTypeKC kbexpertiseinter kbHotfixServer kbqfe kbfix kbmt KB933468 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:933468

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com