"Setup Failed While Installing Sub-Component Exchange ActiveSync With Error Code 0xC0070641" Error Message Occurs When You Try to Install Exchange Server 2003

Article translations Article translations
Article ID: 820118 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

When you try to install Exchange Server 2003, you receive the following error message during the installation of the ActiveSync component:
Setup failed while installing sub-component Exchange ActiveSync with error code 0xC0070641 (please consult the installation logs for a detailed description). You may cancel the installation or try the failed step again.
Additionally, when you view the Exchange Server Setup Progress.log file, the following information is logged:
[14:52:11] Calling MSXML installer with command line: "msiexec /i msxml3.msi /q reboot="ReallySuppress""

[14:52:11] Process created ... waiting (-1) [14:52:11] Process has exited with 0x000641

[14:52:11] The command

msiexec /i msxml3.msi /q reboot="ReallySuppress"

failed, returning error code 1601 (The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance.). -- ID:31136 -- ScCreateProcess (C:\SOURCE\TI\3\ADMIN\src\libs\exsetup\hiddenw1.cxx:1821) Error code 0XC0070641 (1601): The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance.

[14:52:11] CAtomOMASync::ScInstallMSXML (C:\SOURCE\TI\3\ADMIN\src\udog\exsetdata\components\server\a_omasync.cxx:647) Error code 0XC0070641 (1601): The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance.

[14:52:11] Leaving CAtomOMASync::ScInstallMSXML

[14:52:11] CAtomOMASync::ScAddRegistryKeys (C:\SOURCE\TI\3\ADMIN\src\udog\exsetdata\components\server\a_omasync.cxx:84) Error code 0XC0070641 (1601): The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance.

[14:52:11] Leaving CAtomOMASync::ScAddRegistryKeys [14:52:11] CBaseAtom::ScAdd (C:\SOURCE\TI\3\ADMIN\src\udog\setupbase\basecomp\baseatom.cxx:939) Error code 0XC0070641 (1601): The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance.

[14:52:11] Service = '' CBaseServiceAtom::ScAdd (C:\SOURCE\TI\3\ADMIN\src\udog\setupbase\basecomp\basesvcatom.cxx:210) Error code 0XC0070641 (1601): The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance.

[14:52:11] Leaving CBaseServiceAtom(Exchange ActiveSync)::ScAdd [14:52:11] mode = 'Install' (61953) CBaseAtom::ScSetup (C:\SOURCE\TI\3\ADMIN\src\udog\setupbase\basecomp\baseatom.cxx:842) Error code 0XC0070641 (1601): The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance.

CAUSE

This problem may occur if the Windows Installer service startup setting is set to Disabled.

WORKAROUND

To work around this problem, re-enable the Windows Installer service, and then click Retry on the Exchange Server Setup error message. To re-enable the Windows Installer service:
  1. Click Start, click Run, type services.msc in the Open box, and then click OK.
  2. In the list of services, double-click Windows Installer.
  3. In the Startup type list, click Manual.
  4. Click Apply, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Properties

Article ID: 820118 - Last Review: December 3, 2007 - Revision: 3.5
APPLIES TO
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Keywords: 
kbbug kbnofix kbprb KB820118

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com