Il profilo comune causa l'accumularsi di file TMP supplementari

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Sintomi

È possibile che il profilo comune causi l'accumularsi di file temporanei supplementari denominati Prf*.tmp e che nel registro eventi applicazioni venga registrato un messaggio di errore analogo al seguente:
Tipo evento: Errore
Origine evento: Userenv
Categoria evento: Nessuna
ID evento: 1000
Data: data
Ora: ora del giorno
Utente: S-1-5-21-#########-##########-##########-####
Computer: NomeComputer
Descrizione:
Impossibile copiare il file \\nomeserver\condivisione\...\Prf???.tmp in R:\Documents and Settings\...\Prf???.tmp. Contattare l'amministratore di rete.
DETTAGLI - Impossibile creare un file, se il file esiste già.

Cause

Questo problema può verificarsi se durante la sincronizzazione del profilo il file temporaneo indicato è stato aperto dal Servizio di indicizzazione o da un altro processo, come ad esempio l'agente di un file aperto. In questo caso il file temporaneo non verrà eliminato. Viene caricato con il profilo comune quando l'utente si disconnette e viene riconciliato nel profilo locale durante l'accesso successivo.

Sebbene il problema possa essere causato anche dal software antivirus, di solito l'impatto è minimo poiché per questi processi il numero di operazioni sui file è inferiore rispetto a quelle eseguite dal Servizio indicizzazione e da agenti di file aperti.

Risoluzione

Per risolvere il problema, utilizzare uno dei metodi descritti di seguito:
  • Disattivare il software o il servizio in conflitto con il modulo di gestione dei profili.

    Oppure
  • Escludere le cartelle dei profili dalla funzionalità di monitoraggio o dalla scansione operativa in conflitto.
Si consiglia di esaminare i file prima di eliminarli in modo da avere la certezza che non contengano dati utili. Il modulo di gestione dei profili non elimina i file Prf*.tmp per evitare possibili perdite di dati.

Status

Si tratta di un comportamento legato alla progettazione del prodotto. La riconciliazione del profilo è studiata in particolare per evitare perdite di dati mediante la conservazione dei file temporanei.

Informazioni

Descrizione dettagliata

  1. Se durante la sincronizzazione e riconciliazione del profilo nel modulo di gestione dei profili (USERENV) viene rilevato che un file nel profilo di destinazione è più vecchio dell'equivalente profilo di origine, il file di origine viene copiato in un file Prf*.tmp nel profilo di destinazione.
  2. Il file di destinazione meno recente viene eliminato e il file Prf*.tmp viene rinominato nel modo corretto.

    I nomi di file temporanei vengono generati dalla funzione API GetTempFileName dell'I/O file di Windows. Se il file temporaneo viene aperto da un altro processo prima di essere eliminato e non viene chiuso, il file non verrà rimosso. In presenza di questo comportamento, i messaggi di eventi non vengono scritti nel registro eventi applicazioni. Per ulteriori informazioni, vedere l'argomento "Informazioni sulle registrazioni di Userenv" in questo articolo.
  3. Al momento della disconnessione, i rimanenti file Prf*.tmp vengono caricati automaticamente con il profilo.
  4. Al successivo accesso, se si riutilizzano nomi di file temporanei si verificheranno errori di creazione dei file durante la riconciliazione del profilo. Questa condizione genera l'ID evento 1000 di Userenv descritto nella sezione "Sintomi" di questo articolo.

Informazioni sulle registrazioni di Userenv

È possibile che i seguenti file Prf*.tmp non vengano eliminati:
  • File dei criteri di sistema di Microsoft Windows NT 4.0 (questi file si trovano sempre nella directory principale del profilo).

    Se questi file non vengono eliminati, significa che i file temporanei non sono stati rimossi, non che il criterio non è stato applicato. In questa situazione, nel registro eventi di Userenv vengono registrati dati analoghi ai seguenti:
    USERENV() hh:mm:ss:nnn ApplySystemPolicy: Failed to delete policy file PRF###.TMP. Error 32
  • File di gestione temporanea del profilo standard (questi file non si troveranno mai nella directory principale del profilo).

    Se il file di destinazione esistente non può essere eliminato, anche il file Prf*.tmp non potrà essere rimosso. Il problema può verificarsi se entrambi i file sono aperti da un altro processo. In questo caso, non verranno effettuati altri tentativi di eliminazione del file Prf*.tmp, quindi la copia locale del file risulterà obsoleta (mentre la copia più recente sarà contenuta nel file temporaneo). In questa situazione, nel registro eventi di Userenv vengono registrati dati analoghi ai seguenti:
    USERENV() hh:mm:ss:nnn ReconcileFile: Failed to delete file nomefile with error = 32
    In alcuni casi il file di destinazione esistente è stato eliminato come normale operazione preliminare per rinominare un file temporaneo, ma non è stato possibile rinominare il file Prf*.tmp. I file temporanei, in questo caso, non vengono eliminati proprio per evitare perdite di dati. Nel registro eventi di Userenv vengono registrati dati analoghi ai seguenti:
    USERENV() hh:mm:ss:nnn ReconcileFile: Failed to rename file PRF###.TMP to nomefile with error = 32
NOTA: l'errore 32 viene definito come segue:
ERROR_SHARING_VIOLATION
Impossibile accedere al file. Il file è utilizzato da un altro processo.

Proprietà

Identificativo articolo: 328607 - Ultima modifica: martedì 21 febbraio 2006 - Revisione: 3.0
Le informazioni in questo articolo si applicano a
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
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