Article ID: 3007794 - View products that this article applies to.
Expand all | Collapse all

Symptoms

When a database fails over to a cross-site database availability group (DAG), the Microsoft Exchange Server 2010 Hub Transport server cannot deliver messages to a mounted database, and the mailbox delivery queue on the Hub Transport server may begin growing with deliveries destined to the failed over database.

Cause

This issue occurs because the LastMountedServer value and CurrentlyMountedServer values diverge for a long time.

Resolution

To resolve this issue, install Update Rollup 8 for Exchange Server 2010 Service Pack 3.

Workaround

To work around this issue, use one of the following methods:
  • Restart the Microsoft Exchange Transport Service on Hub Transport server. 
  • Open Exchange Management Shell, and then run the following cmdlet on the Hub Transport server:
    Retry-Queue submission-queue -resubmit:$true

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about the Retry-Queue cmdlet, see general information about Retry Queues.

Properties

Article ID: 3007794 - Last Review: December 9, 2014 - Revision: 1.0
Applies to
  • Microsoft Exchange Server 2010 Service Pack 3, when used with:
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
Keywords: 
kbqfe kbfix kbsurveynew kbexpertiseinter KB3007794

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com