Cómo mostrar y utilizar el cuadro de diálogo Archivo en Microsoft Access 2002

Seleccione idioma Seleccione idioma
Id. de artículo: 279508 - Ver los productos a los que se aplica este artículo
Este artículo se publicó anteriormente con el número E279508
Para obtener una versión para Microsoft Office Access 2003 de este artículo, vea 824272.
Avanzado: requiere conocimientos avanzados de código, interoperabilidad y multiusuario.

Este artículo se refiere a una base de datos de Microsoft Access (.mdb) y a un proyecto de Microsoft Access (.adp).

Expandir todo | Contraer todo

Resumen

En este artículo se muestra cómo utilizar el nuevo método FileDialog de Microsoft Access para mostrar el cuadro de diálogo Archivo integrado y determinar qué archivos seleccionó el usuario.

NOTA
El método FileDialog sólo funciona en la versión comercial completa de Microsoft Access. No funciona en una aplicación de tiempo de ejecución de Microsoft Access.

Más información

En las versiones anteriores de Microsoft Access, no podía mostrar el cuadro de diálogo Archivo sin utilizar el control ActiveX Microsoft Common Dialog o sin hacer llamadas a la API de Windows.

En Microsoft Access 2002, el método FileDialog le permite mostrar el cuadro de diálogo Archivo que utiliza Microsoft Access y determinar los archivos que seleccionó el usuario. La colección SelectedItems del objeto FileDialog contiene las rutas de acceso de los archivos seleccionados por el usuario. Con un bucle For...Each, puede enumerar esta colección y mostrar cada archivo. En el ejemplo siguiente se recorre la colección ItemsSelected y se muestran los archivos en un cuadro de lista.

Microsoft proporciona ejemplos de programación con fines ilustrativos únicamente, sin ninguna garantía tanto expresa como implícita. Esto incluye, entre otras, las garantías implícitas de comerciabilidad e idoneidad para un fin determinado. En este artículo se da por supuesto que ya conoce el lenguaje de programación que se muestra, así como las herramientas empleadas para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden explicarle la funcionalidad de un determinado procedimiento, pero no modificarán estos ejemplos para ofrecer mayor funcionalidad ni crearán procedimientos adaptados a sus necesidades específicas.
  1. Abra la base de datos de ejemplo Neptuno.mdb.
  2. Cree un nuevo formulario en blanco en la vista Diseño.
  3. Agregue los controles siguientes al formulario:
       
    Botón de comando
     --------------------------   
    Nombre: cmdFileDialog   
    Título: Agregar archivos 
    OnClick: [Procedimiento de evento 
    Cuadro de lista 
    ------------------------- 
    Nombre: FileList   
    RowSourceType: Lista de valores					
    
  4. En el menú Ver, haga clic en Código para abrir el módulo del formulario en el Editor de Visual Basic.
  5. En el menú Herramientas, haga clic en Referencias.
  6. Haga clic en la casilla Biblioteca de objetos de Microsoft Office 10.0 para activarla.
  7. Haga clic en Aceptar para cerrar el cuadro de diálogo Referencias.
  8. Agregue el código siguiente al módulo del formulario:
    Option Compare DatabaseOption Explicit      Private Sub cmdFileDialog_Click()'Requiere referencia a la Biblioteca de objetos de Microsoft Office 10.0.   Dim fDialog As Office.FileDialog   Dim varFile As Variant   'Borrar el contenido del cuadro de lista.   Me.FileList.RowSource = ""   'Configurar el cuadro de diálogo Archivo.   Set fDialog = Application.FileDialog(msoFileDialogFilePicker)   With fDialog      'Permitir al usuario hacer varias selecciones en el cuadro de diálogo      .AllowMultiSelect = True                  'Establecer el título del cuadro de diálogo.      .Title = "Seleccione uno o varios archivos"      'Borrar los filtros actuales y agregar los suyos propios.      .Filters.Clear      .Filters.Add "Access Databases", "*.MDB"      .Filters.Add "Access Projects", "*.ADP"      .Filters.Add "All Files", "*.*"      'Mostrar el cuadro de diálogo. Si el método .Show vuelve True, el 'usuario escogió por lo menos un archivo. Si el método .Show vuelve 'False, el usuario hizo clic en Cancelar.      If .Show = True Then         'Recorrer cada archivo seleccionado y agregarlo a nuestro cuadro de lista.         For Each varFile In .SelectedItems            Me.FileList.AddItem varFile         Next      Else         MsgBox "Hizo clic en Cancelar en el cuadro de diálogo Archivo."      End If   End WithEnd Sub					
  9. Guarde el formulario como Form1 y ciérrelo.
  10. Abra el formulario Form1 en la vista Formulario.
  11. Haga clic en Agregar archivos. Observe que aparece el cuadro de diálogo Seleccione uno o varios archivos.
  12. Seleccione uno o varios archivos, y haga clic en Aceptar o en Cancelar.
Si seleccionó uno o varios archivos, observe que esos nombres de archivo aparecen en el cuadro de lista. Si hizo clic en Cancelar, observe que recibe un mensaje que lo indica.

Referencias

Para obtener más información acerca de lo que puede hacer con el cuadro de diálogo Archivo, en el Editor de Visual Basic, haga clic en Ayuda de Microsoft Visual Basic, en el menú Ayuda escriba filedialog object en el Ayudante de Office o el Asistente para Ayuda, y a continuación haga clic en Buscar para ver el tema.

Propiedades

Id. de artículo: 279508 - Última revisión: viernes, 20 de octubre de 2006 - Versión: 4.1
La información de este artículo se refiere a:
  • Microsoft Access 2002 Standard Edition
  • Microsoft Visual Basic for Applications 1.0
Palabras clave: 
kbprogramming kbhowto KB279508

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com