ระยะเวลาการเข้าสู่ระบบเมื่อคุณสร้างเซสชัน RD การไปยังเซิร์ฟเวอร์ที่ใช้ Windows Server 2008 R2 โฮสต์ของเซสชัน RD ถ้าเปลี่ยนเส้นทางเครื่องพิมพ์ถูกเปิดใช้งาน

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 2655998
ไม่แน่ใจว่านี่คือการแก้ไขที่ถูกต้องหรือไม่ เราได้เพิ่มประเด็นนี้ของเรา การวินิจฉัยการถ่ายโอนข้อมูลหน่วยความจำ ซึ่งสามารถยืนยัน
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

พิจารณาสถานการณ์สมมติต่อไปนี้:
  • คุณสามารถมีเซิร์ฟเวอร์ที่ใช้ Windows Server 2008 R2 โฮสต์ของเซสชันเดสก์ท็อประยะไกล (RD) ในสภาพแวดล้อมของโดเมน Active Directory
  • คุณสามารถใช้การตั้งค่า'นโยบายกลุ่ม'การเปลี่ยนเส้นทางเครื่องพิมพ์กับเซสชัน RD ที่เชื่อมต่อกับเซิร์ฟเวอร์
  • คุณซ้ำ ๆ สร้างเซสชัน RD ไปยังเซิร์ฟเวอร์จากคอมพิวเตอร์แบบไคลเอ็นต์ที่มีการติดตั้งเครื่องพิมพ์หลายเครื่อง
ในสถานการณ์สมมตินี้ เวลาเข้าสู่ระบบเพิ่มขึ้นทุกครั้งที่คุณสร้างการเชื่อมต่อของ RD นอกจากนี้ นับ"%เวลามีสิทธิ์เพิ่มขึ้นในกระบวนการ Svchost.exe บริการโหมดผู้ใช้ Plug and Play (Umpnpmgr.dll) บนเซิร์ฟเวอร์ที่โฮสต์ ลักษณะการทำงานนี้เกิดขึ้นทุกครั้งที่คุณเข้าสู่ระบบ ออก หรือสร้างเซสชัน RD ผิด

ลักษณะการทำงานนี้อาจทำให้เกิดปัญหาประสิทธิภาพการทำงานเช่นการเริ่มต้นระบบช้า เข้าสู่ระบบช้า แฮงค์ระบบ หรือความล้มเหลวในการเปลี่ยนเส้นทางเครื่องพิมพ์ และแมปไดรฟ์

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากบริการระยะไกลเดสก์ท็อปบริการอุปกรณ์ตัวเปลี่ยนเส้นทางสร้างพอร์ตใหม่ทุกครั้งที่สำเร็จเซสชัน RD อย่างไรก็ตาม พอร์ตที่ไม่ได้ใช้งานจะไม่นำงาน แทน พอร์ตที่ไม่ได้ใช้งานสำหรับเครื่องพิมพ์ที่เปลี่ยนเส้นทางสะสมอยู่ภายใต้คีย์รีจิสทรีต่อไปนี้บนเซิร์ฟเวอร์:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceClasses\{28d78fad-5a12-11d1-ae5b-0000f803a8c2}\##?#Root#RDPBUS#0000#{28d78fad-5a12-11d1-ae5b-0000f803a8c2}\

การแก้ไข

ข้อมูลโปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนที่สนับสนุนได้จาก Microsoft อย่างไรก็ตาม โปรแกรมแก้ไขด่วนนี้มุ่งหวังเพื่อการแก้ไขปัญหาที่อธิบายไว้ในบทความนี้ ใช้ hotfix นี้เฉพาะกับระบบต่าง ๆ ที่พบปัญหาอธิบายไว้ในบทความนี้ โปรแกรมแก้ไขด่วนนี้อาจได้รับการทดสอบเพิ่มเติม ดังนั้น ถ้าคุณจะไม่รุนแรงได้รับผลกระทบจากปัญหานี้ เราขอแนะนำให้ คุณรอการปรับปรุงซอฟต์แวร์ถัดไปที่ประกอบด้วยโปรแกรมแก้ไขด่วนนี้

หากโปรแกรมแก้ไขด่วนพร้อมสำหรับการดาวน์โหลด คุณจะเห็นส่วน "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" ที่ด้านบนของบทความฐานข้อมูลองค์ความรู้นี้ หากส่วนนี้ไม่ปรากฏขึ้น ติดต่อ Microsoft ฝ่ายบริการลูกค้าและฝ่ายสนับสนุนเพื่อขอรับโปรแกรมแก้ไขด่วน

หมายเหตุ ถ้ามีปัญหาอื่น ๆ เกิดขึ้น หรือถ้าการแก้ไขปัญหาใด ๆ ที่จำเป็น คุณอาจต้องสร้างการร้องขอบริการแยกต่างหาก ระบุต้นทุนในการสนับสนุนปกติจะใช้กับคำถามเพิ่มเติมและเรื่องอื่น ๆ ที่ไม่มีสิทธิได้รับโปรแกรมแก้ไขด่วนนี้เฉพาะ สำหรับรายชื่อทั้งหมด ของหมายเลขโทรศัพท์ของฝ่ายบริการลูกค้าของ Microsoft และการสนับสนุน หรือ เพื่อสร้างการร้องขอบริการแยกต่างหาก แวะไปที่เว็บไซต์ของ Microsoft ต่อไปนี้:
http://support.microsoft.com/contactus/?ws=support
หมายเหตุ แบบฟอร์ม "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" แสดงภาษาโปรแกรมแก้ไขด่วนจะพร้อมใช้งาน ถ้าคุณไม่เห็นภาษาของคุณ ได้เนื่องจากไม่มีโปรแกรมแก้ไขด่วนพร้อมใช้งานสำหรับภาษานั้น

ข้อกำหนดเบื้องต้น

เมื่อต้องการใช้โปรแกรมแก้ไขด่วนนี้ คุณต้องเรียกใช้ Windows Server 2008 R2 หรือ Windows Server 2008 R2 Service Pack 1 (SP1) นอกจากนี้ คุณต้องมีบริการบทบาทของโฮสต์ของเซสชัน RD ติดตั้งบนคอมพิวเตอร์

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการขอรับ Windows 7 หรือ Windows Server 2008 R2 เซอร์วิสแพ็ค คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
976932 ข้อมูลเกี่ยวกับ Service Pack 1 สำหรับ Windows 7 และ สำหรับ Windows Server 2008 R2

ข้อมูลรีจิสทรี

เพื่อใช้โปรแกรมแก้ไขด่วนในแพคเกจนี้ คุณไม่จำเป็นต้องทำการเปลี่ยนแปลงใด ๆ ในรีจิสทรี

ข้อกำหนดการรีสตาร์ท

คุณต้องเริ่มระบบคอมพิวเตอร์ใหม่หลังจากที่คุณนำโปรแกรมแก้ไขด่วนนี้ไปใช้แล้ว

ข้อมูลการแทนที่โปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนนี้ไม่ได้ใช้แทนโปรแกรมแก้ไขด่วนที่มีการนำออกใช้ก่อนหน้านี้

ข้อมูลแฟ้ม

รุ่นสากลของโปรแกรมแก้ไขด่วนนี้ติดตั้งแฟ้มที่มีแอตทริบิวต์ที่แสดงในตารางต่อไปนี้ วันที่และเวลาสำหรับแฟ้มเหล่านี้จะแสดงรายการไว้ในรูปแบบเวลามาตรฐานสากล (UTC) วันที่และเวลาสำหรับแฟ้มเหล่านี้บนเครื่องคอมพิวเตอร์ภายในพื้นที่ของคุณจะแสดงผลตามเวลาท้องถิ่นของคุณร่วมกับความโน้มเอียงของเวลาตามฤดูกาล (DST) ในปัจจุบันของคุณ นอกจากนี้ วันที่และเวลาอาจจะเปลี่ยนแปลงไปได้อีกด้วยเมื่อคุณดำเนินการบางอย่างกับแฟ้มนี้
หมายเหตุข้อมูลแฟ้มของ Windows Server 2008 R2
  • แฟ้มที่ใช้กับผลิตภัณฑ์เจาะจง เหตุการณ์สำคัญ (RTM, SPn), และสาขาเซอร์วิส (LDR, GDR) สามารถระบุได้ ด้วยการตรวจสอบหมายเลขรุ่นของแฟ้มดังที่ปรากฏในตารางต่อไปนี้:
    ยุบตารางนี้ขยายตารางนี้
    เวอร์ชั่นผลิตภัณฑ์หลักเป้าหมายสาขาเซอร์วิส
    6.1.760 0.21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows Server 2008 R2SP1LDR
  • แฟ้ม MANIFEST (.manifest) และแฟ้ม MUM (.mum) ที่ติดตั้งสำหรับแต่ละสภาพแวดล้อม แสดงรายการแยกต่างหาก ในส่วน "ข้อมูลแฟ้มเพิ่มเติมสำหรับ Windows Server 2008 R2" แฟ้ม MUM และแฟ้ม MANIFEST และ แฟ้มแค็ตตาล็อก (.cat) การรักษาความปลอดภัยที่เกี่ยวข้อง มีความสำคัญอย่างมากในการรักษาสถานะของคอมโพเนนต์ปรับปรุงแล้ว แฟ้มแค็ตตาล็อกการรักษาความปลอดภัยซึ่งแอตทริบิวต์ไม่ได้แสดงรายการไว้จะได้รับการลงชื่อด้วยลายเซ็นดิจิทัลของ Microsoft
สำหรับ Windows Server 2008 R2 รุ่นที่ใช้ x64 ที่รองรับทั้งหมด
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดของแฟ้มวันที่เวลาแพลตฟอร์ม
Umrdp.dll6.1.7600.21124195,58411-ม.ค.-201206:28x 64
Umrdp.dll6.1.7601.21895214,52811-ม.ค.-201206:23x 64

สถานะ

Microsoft ยืนยันว่านี่เป็นปัญหาในผลิตภัณฑ์ของ Microsoft ซึ่งแสดงไว้ในส่วน "นำไปใช้กับ"

ข้อมูลเพิ่มเติม

หลังจากที่คุณติดตั้งโปรแกรมแก้ไขด่วนนี้ คุณจะต้องไปลบพอร์ตของเซิร์ฟเวอร์เทอร์มินัลไม่ได้ใช้งานอยู่ในขณะนี้ โปรแกรมแก้ไขด่วนนี้ป้องกันไม่ให้พอร์ตเซิร์ฟเวอร์เทอร์มินัลไม่ได้ใช้งานหลัง ดังนั้น คุณเพียงแค่ลบพอร์ตหนึ่งครั้งหลังจากที่คุณติดตั้งโปรแกรมแก้ไขด่วนนี้บน Windows Server 2008 R2

เมื่อต้องการให้เราลบพอร์ตเซิร์ฟเวอร์เทอร์มินัลไม่ได้ใช้งานอยู่ในขณะนี้สำหรับคุณ ไป "แก้ไขปัญหานี้ให้ฉัน"ส่วน

แก้ไขปัญหานี้ให้ฉัน



เมื่อต้องการเอาออกเซิร์ฟเวอร์เทอร์มินัลไม่ได้ใช้งานพอร์ตปัจจุบันโดยอัตโนมัติ การFix it ปุ่มหรือการเชื่อมโยง แล้วคลิก Run ในกล่องโต้ตอบ File Download และทำตามขั้นตอนในตัวช่วยสร้าง Fix it


แก้ไขปัญหานี้
Microsoft Fix it 50833


หมายเหตุ
  • Fixit นี้ยังใช้เพื่อล้างข้อมูลไม่ได้ใช้งานเทอร์มินัลเซิร์ฟเวอร์พอร์ตบนรุ่นทั้งหมดของ Windows Server 2003 และ Windows Server 2008, Windows 7 ina VDI สถานการณ์จำลอง และสามารถเป็นแบบอัตโนมัติเมื่อต้องการเรียกใช้ตามกำหนดเวลาไว้ สำหรับข้อมูลเพิ่มเติม โปรดดูที่http://blogs.technet.com/b/askperf/archive/2012/03/06/performance-issues-due-to-inactive-terminal-server-ports.aspx.
  • ตัวช่วยสร้างนี้อาจเป็นภาษาอังกฤษเท่านั้น อย่างไรก็ตาม การแก้ไขอัตโนมัติจะทำงานกับ Windows รุ่นภาษาอื่น
  • ถ้าคุณไม่ใช้คอมพิวเตอร์ที่มีปัญหา บันทึกโซลูชัน Fix it ไปยังแฟลชไดรฟ์หรือซีดีแล้ว เรียกใช้บนคอมพิวเตอร์ที่มีปัญหา
สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการเปลี่ยนเส้นทางเครื่องพิมพ์ แวะไปที่เว็บไซต์ของ Microsoft ต่อไปนี้:สำหรับข้อมูลเพิ่มเติมเกี่ยวกับศัพท์เฉพาะในการปรับปรุงซอฟต์แวร์ ให้คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
824684 คำอธิบายเกี่ยวกับคำศัพท์มาตรฐานที่ใช้อธิบายการปรับปรุงซอฟต์แวร์ของ Microsoft

ข้อมูลแฟ้มเพิ่มเติม

ข้อมูลแฟ้มเพิ่มเติมสำหรับ Windows Server 2008 R2

แฟ้มเพิ่มเติมสำหรับทั้งหมดได้รับการสนับสนุน Windows Server 2008 R2 รุ่นที่ใช้ x64
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มAmd64_3fa953577d7d1ef5281e74af83e76b68_31bf3856ad364e35_6.1.7600.21124_none_283f0e03f23d0d0a.manifest
รุ่นของแฟ้มไม่มีข้อมูล
ขนาดของแฟ้ม723
วัน (UTC)11-ม.ค.-2012
เวลา (UTC)11:12
แพลตฟอร์มไม่มีข้อมูล
ชื่อแฟ้มAmd64_5bfeae5b817170f1bd59c2ed5ba20fcf_31bf3856ad364e35_6.1.7601.21895_none_d2977157f84c5304.manifest
รุ่นของแฟ้มไม่มีข้อมูล
ขนาดของแฟ้ม723
วัน (UTC)11-ม.ค.-2012
เวลา (UTC)11:12
แพลตฟอร์มไม่มีข้อมูล
ชื่อแฟ้มAmd64_microsoft-windows-t ...ices-portredirector_31bf3856ad364e35_6.1.7600.21124_none_be673547d7e28cb7.manifest
รุ่นของแฟ้มไม่มีข้อมูล
ขนาดของแฟ้ม20,927
วัน (UTC)11-ม.ค.-2012
เวลา (UTC)07:22
แพลตฟอร์มไม่มีข้อมูล
ชื่อแฟ้มAmd64_microsoft-windows-t ...ices-portredirector_31bf3856ad364e35_6.1.7601.21895_none_c0030b01d540a24f.manifest
รุ่นของแฟ้มไม่มีข้อมูล
ขนาดของแฟ้ม20,927
วัน (UTC)11-ม.ค.-2012
เวลา (UTC)07:27
แพลตฟอร์มไม่มีข้อมูล

คุณสมบัติ

หมายเลขบทความ (Article ID): 2655998 - รีวิวครั้งสุดท้าย: 9 ตุลาคม 2557 - Revision: 8.0
Keywords: 
kbmdd kbautohotfix kbqfe kbhotfixserver kbfix kbprint kbrd kbsurveynew kbexpertiseinter kbfixme kbmsifixme kbmt KB2655998 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:2655998

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com