Dlhé čase prihlasovania pri vytvorení RD reláciu na server Windows Server 2008 R2-založené hosť RD relácie ak presmerovaním zapnutá

Preklady článku Preklady článku
ID článku: 2655998
Nie ste si istí, či je právo opraviť? Pridali sme tento problém na našich výpis pamäte diagnostický ktoré potvrdiť.
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

Príznaky

Predstavte si nasledujúcu situáciu:
  • Máte server so systémom Windows Server 2008 R2 hostiteľa relácie vzdialenej skúsenosti s prácou s počítačom (RD) v prostredí domény služby Active Directory.
  • RD relácie, pripojenie na server použijete nastavenie politiky skupiny presmerovanie tlačiarne.
  • Vytvoríte opakovane RD relácie server z klientskeho počítača, ktorý má viacero tlačiarní, ktoré sú nainštalované.
V tomto prípade prihlásení zvyšuje zakaždým, že ste spojenie RD. Okrem toho počet % privilegovaného časuzvyšuje proces Svchost.exe hostí službe používateľského režimu Plug and Play (Umpnpmgr.dll) na serveri. K tomuto správaniu dochádza vždy, keď sa prihlásite, odhlásenie alebo obnoviť RD relácie.

Toto správanie môže spôsobiť problémy s výkonom pomalé spúšťanie, pomalé prihlasovanie, systém zablokovanie alebo zlyhanie presmerovanie tlačiarne a pripojené jednotky.

Príčina

Tento problém sa vyskytuje, pretože služby Remote Desktop služby zariadenia Presmerovač vytvorí nový port vždy, keď sa zistí RD relácie. Neaktívne porty však nie sú recyklované. Namiesto toho neaktívne porty presmerovanej tlačiarne zhromažďovať v nasledovnom kľúči databázy registry na serveri:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceClasses\{28d78fad-5a12-11d1-ae5b-0000f803a8c2}\##?#Root#RDPBUS#0000#{28d78fad-5a12-11d1-ae5b-0000f803a8c2}\

Riešenie

Informácie o rýchlej oprave

Podporovaná rýchla oprava je k dispozícii od spoločnosti Microsoft. Táto rýchla oprava je však určená iba problém, ktorý je popísaný v tomto článku. Rýchlu opravu použite len v systémoch, ktoré sa vyskytuje problém popísaný v tomto článku. Možno, že táto rýchla oprava bude ďalej testovaná. Ak nie sú výrazne ovplyvnený týmto problémom, odporúčame vám počkať na ďalšiu aktualizáciu softvéru, ktorá obsahuje túto rýchlu opravu.

Ak je rýchla oprava k dispozícii na prevzatie, je "Prevzatie dostupnej rýchlej opravy" sekcia na začiatku tohto článku databázy Knowledge Base. Ak sa táto sekcia nezobrazuje, obráťte sa na oddelenie služieb zákazníkom spoločnosti Microsoft a podporu získať rýchlu opravu.

Poznámka: Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť problémy, je možné, že budete musieť vytvoriť samostatnú servisnú požiadavku. Na ďalšie žiadosti o podporu a problémy, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, sa vzťahujú zvyčajné poplatky za poskytnutie technickej podpory. Úplný zoznam služieb zákazníkom spoločnosti Microsoft a podpora telefónne čísla alebo vytvorte samostatnú servisnú požiadavku, navštívte nasledujúcu webovú lokalitu spoločnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "Prevzatie dostupnej rýchlej opravy" formulár sa zobrazujú jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, znamená to, že rýchla oprava nie je pre tento jazyk k dispozícii.

Požiadavky

Ak chcete použiť túto rýchlu opravu, musíte používať systém Windows Server 2008 R2 alebo Windows Server 2008 R2 Service Pack 1 (SP1). Okrem toho musí mať služby roly hostiteľa relácie RD v počítači.

Ďalšie informácie o získaní systému Windows 7 alebo Windows Server 2008 R2 service pack nájdete po kliknutí na nasledovné číslo článku publikovaného v databáze Microsoft Knowledge Base:
976932 Informácie o balíku Service Pack 1 pre systémy Windows 7 a Windows Server 2008 R2

Informácie o databáze Registry

Ak chcete použiť rýchlu opravu v tomto balíku, nemáte robiť žiadne zmeny v databáze Registry.

Požiadavka na reštartovanie

Po použití tejto rýchlej opravy je nutné reštartovať počítač.

Informácie o nahradení rýchlej opravy

Táto rýchla oprava nenahrádza predchádzajúcu rýchlu opravu.

Informácie o súboroch

Globálna verzia tejto rýchlej opravy inštaluje súbory, ktorých atribúty sú uvedené v nasledujúcich tabuľkách. Dátumy a časy jednotlivých súborov sú uvedené vo formáte UTC (Coordinated Universal Time). Dátumy a časy pre tieto súbory v lokálnom počítači sú zobrazené v miestnom čase a podľa aktuálneho nastavenia funkcie prechodu na letný čas. Dátumy a časy sa okrem toho môžu zmeniť aj pri vykonávaní určitých operácií so súbormi.
Windows Server 2008 R2 súbor informácií poznámky
  • Súbory vzťahujúce sa na konkrétny produkt, medzník (RTM, SPn), a priečinok služby (LDR, GDR) je identifikovať na základe kontroly čísel verzií súborov tak, ako je uvedené v nasledujúcej tabuľke:
    Zbaliť túto tabuľkuRozbaliť túto tabuľku
    VerziaProduktMedzníkPriečinok služby
    6.1.760 0.21XXXWindows Server 2008 R2RTMOBMEDZENÚ
    6.1.760 1.21XXXWindows Server 2008 R2SP1OBMEDZENÚ
  • Súbory typu MANIFEST (.manifest) a súbory MUM (.mum), sa inštalujú pre jednotlivé prostredia, sú uvedené samostatne v časti "Ďalšie informácie o súboroch pre systémy Windows Server 2008 R2". Súbory MUM a súbory MANIFEST a priradené súbory katalógu zabezpečenia (.cat), sú mimoriadne dôležité na zachovanie stavu aktualizovaných súčastí. Súbory katalógov zabezpečenia, pre ktoré nie sú uvedené atribúty, sú podpísané digitálnym podpisom spoločnosti Microsoft.
Pre všetky podporované x 64-bitových verziách systému Windows Server 2008 R2
Zbaliť túto tabuľkuRozbaliť túto tabuľku
Názov súboruVerzia súboruVeľkosť súboruDátumČasPlatforma
Umrdp.dll6.1.7600.21124195,58411-Jan-201206:28x64
Umrdp.dll6.1.7601.21895214,52811-Jan-201206:23x64

Stav

Spoločnosť Microsoft potvrdila, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti Vzťahuje sa na.

Ďalšie informácie

Po nainštalovaní tejto rýchlej opravy, si musíte odstrániť všetky porty momentálne neaktívne terminálového servera. Táto rýchla oprava zabraňuje neaktívne Terminal Server portov hromadia. Preto stačí odstrániť porty raz po inštalácii tejto rýchlej opravy v systéme Windows Server 2008 R2.

Aby sme odstránili momentálne neaktívne terminálového servera porty za vás, prejdite na "Opravte to za mňa"sekcia.

Opravte to za mňa



Ak chcete automaticky odstrániť všetky aktuálne neaktívne terminálový Server portov, spravit tlačidlo alebo prepojenie. Potom kliknite na položku spustiť v dialógovom okne Prevzatie súboru a postupujte podľa pokynov sprievodcu Fix it .


Tento problém vyriešiť
Microsoft Fix it 50833


Poznámky
  • Fixit môže použiť aj na čistenie neaktívne Terminal Server portov vo všetkých verziách systému Windows Server 2003 a Windows Server 2008, Windows 7 ina VDI scenár a zautomatizovať spustiť podľa plánu. Ďalšie informácie nájdetehttp://blogs.TechNet.com/b/askperf/Archive/2012/03/06/Performance-issues-Due-to-Inactive-Terminal-Server-Ports.aspx.
  • Tento sprievodca môže byť dostupný iba v angličtine. Automatická oprava však funguje aj pre ostatné jazykové verzie systému Windows.
  • Ak nie ste v počítači, ktorý má problém, uložte Fix it riešenie na jednotku flash alebo na disk CD a potom ho môžete spustiť v problémovom počítači.
Ďalšie informácie o presmerovanie tlačiarne, nájdete na nasledujúcej webovej lokalite spoločnosti Microsoft:
Všeobecné informácie o presmerovanie tlačiarne
Ďalšie informácie o terminológii z oblasti aktualizácií softvéru získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:
824684 Popis štandardnej terminológie používanej na popis aktualizácií softvéru od spoločnosti Microsoft

Ďalšie informácie o súboroch

Ďalšie informácie o súboroch pre systém Windows Server 2008 R2

Ďalšie súbory pre všetky podporované x 64-bitových verziách systému Windows Server 2008 R2
Zbaliť túto tabuľkuRozbaliť túto tabuľku
Názov súboruAmd64_3fa953577d7d1ef5281e74af83e76b68_31bf3856ad364e35_6.1.7600.21124_none_283f0e03f23d0d0a.manifest
Verzia súboruNevzťahuje sa
Veľkosť súboru723
Dátum (UTC)11-Jan-2012
Čas (UTC)11:12
PlatformaNevzťahuje sa
Názov súboruAmd64_5bfeae5b817170f1bd59c2ed5ba20fcf_31bf3856ad364e35_6.1.7601.21895_none_d2977157f84c5304.manifest
Verzia súboruNevzťahuje sa
Veľkosť súboru723
Dátum (UTC)11-Jan-2012
Čas (UTC)11:12
PlatformaNevzťahuje sa
Názov súboruAmd64_microsoft-windows-t...ICES portredirector_31bf3856ad364e35_6.1.7600.21124_none_be673547d7e28cb7.manifest
Verzia súboruNevzťahuje sa
Veľkosť súboru20,927
Dátum (UTC)11-Jan-2012
Čas (UTC)07:22
PlatformaNevzťahuje sa
Názov súboruAmd64_microsoft-windows-t...ICES portredirector_31bf3856ad364e35_6.1.7601.21895_none_c0030b01d540a24f.manifest
Verzia súboruNevzťahuje sa
Veľkosť súboru20,927
Dátum (UTC)11-Jan-2012
Čas (UTC)07:27
PlatformaNevzťahuje sa

Vlastnosti

ID článku: 2655998 - Posledná kontrola: 10. októbra 2014 - Revízia: 8.0
Kľúčové slová: 
kbmdd kbautohotfix kbqfe kbhotfixserver kbfix kbprint kbrd kbsurveynew kbexpertiseinter kbfixme kbmsifixme kbmt KB2655998 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok je preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft a možno ho opraviť prostredníctvom technológie Community Translation Framework (CTF). Microsoft ponúka strojovo preložené články, články upravené komunitou aj články preložené prekladateľmi, aby zabezpečil prístup ku všetkým článkom databázy Knowledge Base vo viacerých jazykoch. Strojovo preložené články aj upravené články môžu obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky. Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené neprávnym prekladom obsahu alebo jeho použitím zo strany našich zákazníkov. Ďalšie informácie o technológii CTF nájdete na lokalite http://support.microsoft.com/gp/machine-translation-corrections/sk.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 2655998

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com