"0x0000003B" error de detención cuando usted controlar remotamente una sesión de escritorio remoto en Windows Server 2008 R2

Seleccione idioma Seleccione idioma
Id. de artículo: 2525246 - Ver los productos a los que se aplica este artículo
¿No está seguro de si esta es la razón? Hemos añadido este problema a nuestra diagnóstico de volcado de memoria que puede confirmar.
Expandir todo | Contraer todo

En esta página

Síntomas

Considere el siguiente escenario:
  • Instalar el rol de Host de sesión de escritorio remoto en un equipo que ejecuta Windows Server 2008 R2.
  • Se inicia para controlar remotamente una sesión de escritorio remoto o que controle de forma remota una sesión de escritorio remoto desde otra sesión de escritorio remoto en el equipo.

    Nota: Esta operación que realice se conoce como "sombreado".
En este caso, recibirá un mensaje de error Stop similar al siguiente:
PARADA: (0X0000003B parámetro1, parámetro2, parámetro3, parámetro4 )
El SYSTEM_SERVICE_EXCEPTION

Notas
  • No todos los errores de detención de "0x0000003B" son causados por este problema.
  • Los parámetros de este mensaje de error varían, dependiendo de la configuración del equipo.

Información para desarrolladores

Este problema se produce cuando ambas de las siguientes acciones se llevan a cabo al mismo tiempo en una sesión de escritorio remoto:
  • Una aplicación o servicio llama a la función EnumDisplaySettings .
  • Se inicia para controlar de forma remota otra sesión de escritorio remoto o que controle de forma remota otra sesión de escritorio remoto.

Causa

Este problema se produce porque el controlador de pantalla de Remote Desktop Protocol (RDP) (Rdpdd.sys) no comprueba si un objeto es NULL antes de Rdpdd.sys obtiene acceso al objeto. Por lo tanto, este problema se produce cuando Rdpdd.sys tiene acceso a un objeto que tiene un valor nulo .

Solución

Información de la revisión

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, envíe una solicitud al servicio de atención al cliente y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si necesita solucionar un problema, tendrá que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las cuestiones y problemas que no guarden relación con esta revisión en cuestión. Para obtener una lista completa de los números de teléfono de soporte técnico de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Nota: El formulario de "Descarga de revisión disponible" muestra los idiomas para los que la revisión está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe ejecutar uno de los siguientes sistemas operativos:
  • Windows Server 2008 R2
  • Service Pack 1 (SP1) de Windows Server 2008 R2
Además, debe instalarse el servicio de rol de servicios de escritorio remoto.

Para obtener más información acerca de cómo obtener un service pack de Windows Server 2008 R2, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
976932 Información sobre el Service Pack 1 para Windows 7 y Windows Server 2008 R2

Información del registro

Para utilizar la revisión de este paquete, no es necesario realizar ningún cambio en el registro.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar esta revisión.

Información de reemplazo de hotfix

Esta revisión no sustituye a ninguna revisión publicada previamente.

Información de archivo

La versión global de esta revisión instala archivos que tienen los atributos enumerados en las tablas siguientes. Las fechas y las horas de estos archivos se muestran en la hora Universal coordinada (UTC). Se muestran las fechas y las horas de estos archivos en el equipo local en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.
Notas sobre la información de archivo de Windows Server 2008 R2
Importante Se incluyen las correcciones urgentes de Windows 7 y Windows Server 2008 R2 en los mismos paquetes. Sin embargo, las revisiones en la página de solicitud de revisión se muestran en ambos sistemas operativos. Para solicitar el paquete de revisiones que se aplica a uno o ambos sistemas operativos, seleccione la revisión que aparece en "Windows 7/Windows Server 2008 R2" en la página. Siempre hacen referencia a la sección "Se aplica a" de los artículos para determinar el sistema operativo real que se aplica cada revisión.
  • Los archivos que se aplican a un producto específico, SR_Level (RTM, SPn), y tipo de servicio (LDR, GDR) puede identificarse mediante el examen de los números de versión de archivo como se muestra en la siguiente tabla.
    Contraer esta tablaAmpliar esta tabla
    VersiónProductoSR_LevelTipo de servicio
    6.1.760 0. 20xxxWindows Server 2008 R2RTMLDR
    6.1.760 1. 21xxxWindows Server 2008 R2SERVICE PACK 1LDR
  • Los archivos MANIFEST (.manifest) y el MUM (.mum) instalados para cada entorno están lista por separado en la sección "información adicional de archivos para Windows Server 2008 R2". MUM y los archivos de manifiesto y los archivos de catálogo (.cat) de seguridad asociados, son extremadamente importantes mantener el estado de los componentes actualizados. Los archivos de catálogo de seguridad, para los cuales los atributos no se muestran, están firmados con una firma digital de Microsoft.
Para todas las versiones basadas en x 64 de Windows Server 2008 R2
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataformaTipo de servicio
Rdpwd.sys6.1.7600.20928205,82419-Mar-201105:44x 64No aplicable
Rdpdd.dll6.1.7600.20928194,56019-Mar-201105:43x 64AMD64_MICROSOFT-WINDOWS-T..S-RDP-DISPLAYDRIVER_31BF3856AD364E35_6.1.7600.20928_NONE_414E4D4987942D3F
Rdpdd.dll6.1.7601.21687274,94419-Mar-201105:42x 64AMD64_MICROSOFT-WINDOWS-T..S-RDP-DISPLAYDRIVER_31BF3856AD364E35_6.1.7601.21687_NONE_42F2C89784EC2A53

Solución

Solución para Windows Server 2008 R2

Para evitar este problema, no llame a la función EnumDisplaySettings cuando la operación que controla de forma remota la sesión de escritorio remoto está activa.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft
Para obtener más información acerca de la función EnumDisplaySettings , visite el siguiente sitio Web MSDN:
Información general acerca de la función EnumDisplaySettings

Información adicional de archivos

Información adicional de archivos para Windows Server 2008 R2

Archivos adicionales para todas las versiones basadas en x 64 de Windows Server 2008 R2
Contraer esta tablaAmpliar esta tabla
Nombre de archivoAmd64_1f7ffed2870e4badb2f02a9a7844fb0e_31bf3856ad364e35_6.1.7601.21687_none_0955ba9cb4058cdd.manifest
Versión del archivoNo aplicable
Tamaño de archivo726
Fecha (UTC)21-Mar-2011
Hora (UTC)19:10
PlataformaNo aplicable
Nombre de archivoAmd64_b62498c026920813a651bb4f7f102628_31bf3856ad364e35_6.1.7600.20928_none_1f25f96ec90adb6e.manifest
Versión del archivoNo aplicable
Tamaño de archivo1,097
Fecha (UTC)21-Mar-2011
Hora (UTC)19:10
PlataformaNo aplicable
Nombre de archivoAmd64_microsoft-windows-t...DP-winstationdriver_31bf3856ad364e35_6.1.7600.20928_none_a838009e079dc4ed.manifest
Versión del archivoNo aplicable
Tamaño de archivo3,435
Fecha (UTC)19-Mar-2011
Hora (UTC)08:19
PlataformaNo aplicable
Nombre de archivoAmd64_microsoft-windows-t...s-rdp-displaydriver_31bf3856ad364e35_6.1.7600.20928_none_414e4d4987942d3f.manifest
Versión del archivoNo aplicable
Tamaño de archivo2,816
Fecha (UTC)19-Mar-2011
Hora (UTC)08:30
PlataformaNo aplicable
Nombre de archivoAmd64_microsoft-windows-t...s-rdp-displaydriver_31bf3856ad364e35_6.1.7601.21687_none_42f2c89784ec2a53.manifest
Versión del archivoNo aplicable
Tamaño de archivo2,816
Fecha (UTC)19-Mar-2011
Hora (UTC)08:19
PlataformaNo aplicable
Nombre de archivoUpdate.mum
Versión del archivoNo aplicable
Tamaño de archivo2,762
Fecha (UTC)21-Mar-2011
Hora (UTC)19:10
PlataformaNo aplicable

Propiedades

Id. de artículo: 2525246 - Última revisión: viernes, 10 de octubre de 2014 - Versión: 3.0
La información de este artículo se refiere a:
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Foundation
Palabras clave: 
kbmdd kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseadvanced kbexpertiseinter kbsurveynew kbmt KB2525246 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2525246

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com