You may receive a "Windows Media Player cannot play the file" error message when you try to restart a video in Windows Media Player in a multiple-monitor configuration

Article translations Article translations
Article ID: 904550 - View products that this article applies to.
This article has been archived. It is offered "as is" and will no longer be updated.
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

Symptoms

Consider the following scenario. You play a video in Microsoft Windows Media Player in a multiple-monitor configuration. Then, you switch to a different logged-on user account by using the fast user switching (FUS) feature in Microsoft Windows XP. When you switch back to the original user account and try to restart the video, you experience one of the following problems:
  • You may receive the following error message:
    Windows Media Player cannot play the file. The player might not support the file type or might not support the codec that was used to compress the file. 0xC00D1100
  • Windows Media Player does nothing at all.

Cause

When you switch out of the current environment, the display device becomes unavailable to the Video Mixing Renderer (VMR), and the video stops. When you switch back, the VMR queries Microsoft DirectDraw (DDraw) to determine whether a device is available. In a multiple-monitor configuration, DDraw returns an error instead of telling the VMR that a device is available.

Workaround

To work around this problem, exit and then restart Windows Media Player.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 904550 - Last Review: January 16, 2015 - Revision: 1.0
Applies to
  • Windows Media Player 10
  • Microsoft Windows Media Player 9 Series
Keywords: 
kbnosurvey kbarchive kbprb KB904550

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com