Debug Is Not Initialized on Some Devices with 1394 PC Cards

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Article ID: 315399 - View products that this article applies to.
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Symptoms

If you try to debug by using a 1394 PC Card, debugging may not be turned on in some cases.

Cause

This problem occurs because the hardware abstraction layer (HAL) may not wait long enough for the CardBus bus to be initialized. Or, in other cases, the HAL may not wait long enough for the card to be initialized after power is applied. When this occurs, Windows does not actually start in Debug mode even if you use the correct Boot.ini file switches and Kd1394.dll is loaded.

You can verify whether Debug mode is in use by building a program that contains the following sample code:
void main(void)  {
     _asm {  int 3 }
     return 0;

}
				
If Debug mode is in use, the program hangs (it breaks into the debugger) when you run this code. If Debug mode is not in use, you receive a Dr. Watson error message.

Resolution

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to Obtain the Latest Windows XP Service Pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this fix should have the following file attributes or later:
   Date         Time   Version      Size     File name
   ------------------------------------------------------
   27-Jan-2002  17:56  5.1.2600.28  101,376  Hal.dll
   27-Jan-2002  17:56  5.1.2600.28  128,000  Halaacpi.dll
   27-Jan-2002  17:56  5.1.2600.28   77,440  Halacpi.dll

   27-Jan-2002  17:56  5.1.2600.28  146,432  Halapic.dll
   27-Jan-2002  17:56  5.1.2600.28  130,048  Halmacpi.dll
   27-Jan-2002  17:56  5.1.2600.28  148,352  Halmps.dll
   27-Jan-2002  17:56  5.1.2600.28   75,136  Halsp.dll
				

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows XP Service Pack 1.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 315399 - Last Review: December 24, 2014 - Revision: 1.0
Applies to
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbnosurvey kbarchive kbAutoHotfix kbHotfixServer kbqfe kbbug kbfix kboswin2000fix kbwinxpsp1fix KB315399

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