A DHCP client computer occasionally cannot obtain an IP address from a server that is running a non-Microsoft version of a DHCP service

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Article ID: 835304 - View products that this article applies to.
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SYMPTOMS

A DHCP client computer occasionally cannot obtain an IP address from a server that is running a non-Microsoft version of a Dynamic Host Configuration Protocol (DHCP) service. If you wait for several minutes and then restart the client computer, you may be able to obtain an IP address.

CAUSE

This problem occurs if all the following conditions are true:
  • The client computer's lease of the IP address has expired.
  • The IP address that the client computer was using is no longer available.
  • The client computer is using a non-Microsoft DHCP server.
  • The non-Microsoft DHCP server is configured to ignore "duplicate" DHCP discover messages (DHCPDISCOVER).
This problem occurs because the client computer sends three DHCP discover messages with the Requested Address field set to the client computer's previous IP address. The DHCP client computer always sends three DHCP discover messages if both of the following conditions are true:
  • The client computer's lease of the IP address has expired.
  • The IP address that the client computer was using is no longer available.
The client computer sends three DHCP discover messages to verify that the client computer's former IP address is no longer available. The client computer accepts the IP address that is provided in the third DHCP offer message (DHCPOFFER).

However, if the DHCP server is configured to ignore "duplicate" DHCP discover messages, the DHCP server replies only to the first DHCP discover message with a DHCP offer message. The DHCP server ignores subsequent DHCP discover messages. Therefore, the client computer never receives the third DHCP offer message.

RESOLUTION

To resolve this problem, configure the DHCP server to not ignore "duplicate" DHCP discover messages. For example, if you are using a Lucent VitalQIP DHCP server device, configure the CheckTransactionID=0 parameter in the Dhcpd.pcy file so that the DHCP server answers all DHCP discover messages. Contact the manufacturer of your DHCP server device for information about how to configure this setting.For information about how to contact your DHCP server device manufacturer, visit the following Microsoft Web site:
http://support.microsoft.com/gp/vendors
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Properties

Article ID: 835304 - Last Review: June 16, 2008 - Revision: 2.1
APPLIES TO
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbprb KB835304

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