Windows Server 2003 returns incorrect registry values about error checking and reporting in Performance Monitor to an application, and this causes various exceptions or deadlock situations

Article translations Article translations
Article ID: 955858 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Windows Server 2003 provides some settings to control error checking and reporting in Performance Monitor. These settings are stored in the following registry subkey:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib


However, when an application tries to query the corresponding registry values, the system may return incorrect values. If the application uses these values, it may encounter various exceptions or deadlock situations.

CAUSE

In some cases, the system incorrectly reads the Perflib registry values.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must have Windows Server 2003 Service Pack 1 or Service Pack 2 installed.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 SP1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Advapi32.dll5.2.3790.3328620,54417-Apr-200918:41x86
Windows Server 2003 SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Advapi32.dll5.2.3790.4497619,00817-Apr-200918:55x86
Windows Server 2003 SP1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Advapi32.dll5.2.3790.33281,482,75217-Apr-200916:50IA-64SP1Not Applicable
Wadvapi32.dll5.2.3790.3328620,54417-Apr-200916:50x86SP1WOW
Windows Server 2003 SP2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Advapi32.dll5.2.3790.44971,483,77617-Apr-200916:54IA-64SP2Not Applicable
Wadvapi32.dll5.2.3790.4497619,00817-Apr-200916:54x86SP2WOW
Windows Server 2003 and Windows XP, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Advapi32.dll5.2.3790.33281,065,47217-Apr-200916:49x64SP1Not Applicable
Wadvapi32.dll5.2.3790.3328620,54417-Apr-200916:49x86SP1WOW
Windows Server 2003 SP2 and Windows XP SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Advapi32.dll5.2.3790.44971,065,98417-Apr-200916:57x64SP2Not Applicable
Wadvapi32.dll5.2.3790.4497619,00817-Apr-200916:57x86SP2WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The following registry entries are under the Perflib subkey:
  • EventLogLevel
  • ExtCounterTestLevel
  • OpenProcedureWaitTime
  • LibraryUnloadTime
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
226494 Events for Performance Monitor extensions
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 955858 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional x64 Edition
Keywords: 
kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe KB955858

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com