O serviço Agente de transferência de mensagens continua a aceitar mensagens depois que o disco rígido que contém a pasta MTADATA falhar no Exchange Server 5.5 ou no Exchange Server 2003

Traduções deste artigo Traduções deste artigo
ID do artigo: 839138 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Se você tiver uma falha no disco rígido em um dispositivo de SAN (armazenamento conectado à rede) que é usado para armazenar os arquivos de banco de dados para um computador que está executando o Microsoft Exchange Server 5.5 ou o Microsoft Exchange Server 2003, poderá detectar os seguintes sintomas:
  • O serviço Agente de transferência de mensagem do Microsoft Exchange continuará em execução no computador Exchange Server 5.5. Nesse cenário, o serviço Agente de transferência de mensagens aceita mensagens mesmo depois que o disco rígido que contém a pasta MTADATA falhou.
  • As filas de mensagens em um computador Exchange Server que envia mensagens para este computador Exchange Server 5.5 afetado tornam-se vazia.
  • Tanto os seguintes eventos aparecem no Exchange afetado computador Server 5.5 que tenha o disco rígido que SAN falhou:

    evento 1

    IDENTIFICAÇÃO de evento: 2181
    Origem do evento: MSExchangeMTA
    Tipo de evento: aviso
    Categoria do evento: Processamento interno
    Data: date
    Tempo: time
    Usuário: N/d
    Computador: computername
    Descrição: Um erro de servidor de banco de dados do MTA foi encontrado ao proteger um objeto. Chamado a partir do MTA. Procedimento 101. Código de erro do banco de dados: 2. objeto com defeito: 06000060. [Banco de dados Server XFER - IN 17 38] (14)



    evento 2

    IDENTIFICAÇÃO de evento: 2127
    Origem do evento: MSExchangeMTA
    Tipo de evento: aviso
    Categoria do evento: Brazilian OS
    Data: date
    Tempo: time
    Usuário: N/d
    Computador: computername
    Descrição: Um erro de servidor de banco de dados do MTA foi encontrado. Erro ao acessar o atributo de objeto (AAT) em uma leitura/gravação operação. Nome do arquivo: E: \exchsrvr\mtadata\.\DB00005D.DAT. Arquivo operação: 0. Erro do sistema operacional: 4096. Objeto referenciado: gravação (00000000 => N/d). Erro de objeto referenciado 00000000. [0 DB Server XFER-IN 17] (14)

Após o disco rígido na SAN falhar, as mensagens enviadas para o computador afetado do Exchange Server 5.5 são perdidas.

Causa

Esse problema ocorre porque o Message Transfer Agent serviço continua em execução no computador Exchange Server 5.5 afetado. Esse comportamento ocorre mesmo se o disco de rígido do dispositivo de armazenamento SAN falhar. Como o agente de transferência de mensagem (MTA) está disponível para comunicação de (RPC) chamada de procedimento remoto, o servidor de envio transfere mensagens para o computador Exchange Server 5.5 afetado.

Nesse cenário, o Exchange Server afetado 5.5 computador executa uma operação de gravação atrasada quando ele recebe uma mensagem. Após o servidor afetado executa a operação de gravação atrasada, ele envia uma confirmação de recebimento ao servidor de envio. A confirmação indica que o servidor afetado recebeu a mensagem com êxito. Depois de receber a confirmação, o servidor de envio remove a mensagem da fila de envio. No entanto, quando o servidor afetado tenta gravar fisicamente a mensagem para o disco rígido com falha, ele não é possível fazê-lo. Portanto, a mensagem é perdida.

Resolução

Exchange Server 2003

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Microsoft Exchange Server 2003. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
836993Como obter os service packs mais recentes para o Exchange Server 2003

Exchange Server 5.5

Informações sobre o hotfix

Um hotfix suportado agora está disponível da Microsoft, mas destina-se somente a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Para resolver esse problema, contate o Atendimento Microsoft para obter o hotfix. Para obter uma lista completa de telefones do Atendimento Microsoft e informações sobre os custos de suporte da, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação Em alguns casos, as taxas cobradas pelas ligações para chamadas de suporte podem ser canceladas se um profissional de suporte da Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais de suporte serão aplicados a questões e problemas que não se qualificam à atualização específica em questão de suporte adicionais.

Pré-requisitos

Por causa do dependências de arquivo, esse hotfix exige Exchange Server 5.5 Service Pack 4. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
191014Como obter o Service Pack mais recente do Exchange Server 5.5

Requisitos de reinicialização

Em algumas configurações, você precisa reiniciar seu computador após aplicar esse hotfix. T serviço do Microsoft Exchange System Attendant he e todos os seus serviços dependentes são automaticamente interrompidos e reiniciados quando você aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas em tempo de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version            Size    File name        
   --------------------------------------------------------------  
   20-Apr-2004  18:08  5.5.2658.6      1,942,800  Emsmta.exe       
   20-Apr-2004  17:45  5.5.2658.6         69,904  Ems_rid.dll      
   20-Apr-2004  17:45  5.5.2658.6         19,728  Maxapia.dll      
   20-Apr-2004  17:45  5.5.2658.6         12,048  Maxapiv1.dll     
   20-Apr-2004  18:11  5.5.2658.6        167,184  Mtacheck.exe     

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".
Esse problema foi corrigido primeiro no Microsoft Exchange Server 2003 Service Pack 2.

Mais Informações

Para obter informações adicionais sobre como os pacotes de hotfix são nomeados, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
817903Novo esquema para nomeação para pacotes de atualização de software do Exchange Server
Para obter informações adicionais, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
328879Usando o Exchange Server com armazenamento conectado à rede e dispositivos de armazenamento anexado à rede
317172Exchange Server 5.5 e armazenamento anexado à rede

Propriedades

ID do artigo: 839138 - Última revisão: quinta-feira, 15 de janeiro de 2015 - Revisão: 3.2
A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 5.5 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
Palavras-chave: 
kbnosurvey kbarchive kbmt kbexchange550presp5fix kbbug kbfix kbqfe kbhotfixserver KB839138 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 839138
Obtenha mais suporte em smallbusiness.support.microsoft.com

Entre em contato conosco para obter mais ajuda

Entre em contato conosco para obter mais ajuda
Conecte-se com o Answer Desk para obter ajuda especializada.