Evento 8197 repetidamente é registrado no log do aplicativo em um servidor que está executando o Exchange Server 2003 ou Exchange 2000 Server

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Evento 8197 é registrado no log do aplicativo cada 25 minutos em um servidor que está executando o Microsoft Exchange Server 2003 ou Microsoft Exchange 2000 Server.

Esse problema ocorre quando a tarefa de plano de fundo do Exchange Server que controla a pasta de sistema informações de disponibilidade não é capaz de vincular a um servidor de catálogo global. Essa disponibilidade pesquisa tarefa usa o mecanismo de referência do Microsoft Windows para localizar um servidor de catálogo global em vez de usar o componente DSAccess do Exchange Server. Portanto, eventos 8197 repetidamente é registrada mesmo se o Exchange Server parece estar executando corretamente.

Para resolver esse problema, use um ou mais dos seguintes métodos:
  • Método 1: Reiniciar os serviços do Exchange Server
  • Método 2: Verificar as configurações de autenticação LAN Manager
  • Método 3: Resolver problemas de conectividade com o servidor de catálogo global para que a tarefa de pesquisa de disponibilidade tenta vincular
  • Método 4: Verifique se Microsoft Outlook está instalado no servidor do Exchange
Este artigo contém instruções passo a passo para esses métodos. Além disso, este artigo contém mais informações sobre por que eventos 8197 é registrados repetidamente no log de aplicativo.

Sintomas

Em um computador que esteja executando o Exchange Server 2003 ou Exchange 2000 Server, o seguinte evento é registrado no log do aplicativo cada 25 minutos:

Tipo de evento: erro
Origem do evento: MSExchangeFBPublish
Categoria do evento: geral
IDENTIFICAÇÃO de evento: 8197
Computador: ServerName
Descrição: Erro ao inicializar sessão para máquina virtual ComputerName. O número de erro é 0x80040111. Certifique-se de que armazenamento do Microsoft Exchange está sendo executado.

Quando você enfrentar esse problema, outros eventos podem também ser registrados repetidamente no log do aplicativo.

Causa

O motivo mais comum que 8197 de eventos está registrado é que a tarefa de pesquisa de disponibilidade não é capaz de vincular a um servidor de catálogo global.

A maioria das tarefas do Exchange Server usa o componente DSAccess para localizar servidores de catálogo global. No entanto, a tarefa de pesquisa de disponibilidade usa o mecanismo de referência do Windows para localizar um servidor de catálogo global.

O método que usa o mecanismo de referência do Windows para localizar um servidor de catálogo global difere um pouco o método que usa o componente DSAccess. Portanto, a tarefa de pesquisa de disponibilidade não pode usar o servidor de catálogo global mesmo que a maioria das outras tarefas do Exchange Server usam. Portanto, a tarefa de pesquisa de disponibilidade pode ser sem êxito mesmo quando outras tarefas no servidor do Exchange executado corretamente.

"Descrição" linha no caso de mensagem indica que o número do erro é 0x80040111. Esse número de erro corresponde a um erro-2147221231. Erro-2147221231 tem a seguinte definição:
ecLoginFailure MAPI_E_LOGON_FAILED
Evento 8197 pode ser gerado quando pelo menos uma das seguintes condições for verdadeira:
  • Exchange Server não é reiniciado após os controladores de domínio e servidores de catálogo global na organização sejam reiniciados.
  • Em um ambiente Microsoft Windows NT 4.0, você aplicar um modelo de segurança que restringe os métodos de autenticação pode usar o Exchange Server. Como alternativa, você pode modificar configurações de diretiva de segurança que modificar a entrada do Registro LMCompatibilityLevel no servidor do Exchange.
  • Há um problema de conectividade com o servidor de catálogo global para que a tarefa de pesquisa de disponibilidade tenta vincular.
  • Microsoft Outlook está instalado no computador que está executando o Exchange Server.
  • O servidor do Exchange 2000 valida em relação a um servidor de catálogo global em um domínio que não tenha uma relação de confiança correto estabelecida para um domínio do Microsoft Windows NT Server 4.0. Além disso, a conta do serviço Microsoft Exchange Server 5.5 não é possível efetuar logon na caixa de correio do Atendente do sistema.

Resolução

Para resolver esse problema, use um ou mais dos seguintes métodos.

Método 1: Reiniciar os serviços do Exchange Server

Se o Exchange Server não foi reiniciado após os controladores de domínio e os servidores de catálogo global na organização foram reiniciados, você deve reiniciar os serviços do Exchange Server. Para fazer isso, execute as seguintes etapas:
  1. Parar o serviço Microsoft Exchange System Attendant e defina todos os serviços do Exchange Server para o tipo de inicialização manual .
  2. Reinicie o computador que está executando o Exchange Server.
  3. Inicie manualmente todos os serviços do Exchange Server.
  4. Restaure todos os serviços do Exchange Server para seus tipos de inicialização original.

Método 2: Verificar as configurações de autenticação LAN Manager

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756Como fazer backup e restaurar o registro no Windows


Você pode enfrentar o problema é descrito na seção "Sintomas" quando as seguintes condições forem verdadeiras:
  • Você tiver um domínio do Windows NT 4.0 em sua organização.
  • Você aplicar um modelo de segurança que restringe os métodos de autenticação pode usar o Exchange Server. Como alternativa, você pode modificar configurações de diretiva de segurança que modificar a entrada do Registro LMCompatibilityLevel no servidor do Exchange.
Recomendamos que servidores membro em um domínio de Windows NT 4.0 usem uma configuração LMCompatibilityLevel de 1 . Exibir a entrada do Registro LMCompatibilityLevel para determinar se o valor dessa configuração é maior que 1 . Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  3. No painel direito, observe o valor de dados da entrada do Registro LMCompatibilityLevel.
Se esse valor for maior que 1, você deve alterá-lo para 1 . Para fazer isso, modifique a entrada do Registro diretamente.

Essa configuração também pode ser modificada por uma diretiva de grupo. Para verificar se a configuração é modificada por uma diretiva de grupo, exiba o objeto diretiva de grupo do Nível de autenticação LAN Manager . Para fazer isso, siga estas etapas.

Observação Como existem várias versões do Microsoft Windows, as seguintes etapas podem ser diferentes no seu computador. Se estiverem, consulte a documentação do produto para concluir estas etapas.
  1. Em um controlador de domínio, clique em Iniciar , clique em Executar , digite dsa.msc na caixa Abrir e, em seguida, clique em OK .
  2. O Active Directory Users and Computers snap-in que aparece, clique o recipiente no qual a diretiva de grupo está configurada com o botão direito do mouse e, em seguida, clique em Propriedades . Por exemplo, clique o recipiente de domínio com o botão direito do mouse ou clique com o botão direito do mouse na unidade organizacional que contém o servidor do Exchange.
  3. Clique na guia Diretiva de grupo e, em seguida, clique no objeto diretiva de grupo no qual a diretiva é definida.
  4. Clique em Editar .
  5. Expanda Configuração do computador , expanda Configurações do Windows , expanda Configurações de segurança , expanda Diretivas locais e clique em Opções de segurança .
  6. No painel de direito, clique duas vezes em Nível de autenticação LAN Manager .
Para obter mais informações sobre níveis de autenticação LAN Manager, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
823659Cliente, serviço e incompatibilidades do programa que podem ocorrer quando você modificar as configurações de segurança e atribuições de direitos do usuário
305379Problemas de autenticação no Windows 2000 com níveis NTLM 2 acima 2 em um domínio do Windows NT 4.0
239869Como habilitar a autenticação NTLM 2

Método 3: Resolver problemas de conectividade com o servidor de catálogo global para que a tarefa de pesquisa de disponibilidade tenta vincular

Etapa 1: Determinar o servidor de catálogo global para que a tarefa de pesquisa de disponibilidade tenta vincular

  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize a seguinte subchave do Registro:
    HKEY_USERS\.DEFAULT\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\ExchangeAdmin<server name><GUID>
    Observação Para esta subchave do Registro esteja presente, o serviço Microsoft Exchange System Attendant deve estar sendo executado. Use a primeira
    ExchangeAdmin<server name><GUID>
    subchave que aparece em perfis .
  3. Em ExchangeAdmin <server name><GUID>, clique em dca740c8c042101ab4b908002b2fe182 .
  4. No painel direito, exiba os valores de dados para a entrada de registro 001e6602. Os valores de dados semelhantes aos seguintes valores:
    Nome do valor: 001e6602
    Tipo de valor: REG_SZ
    Dados do valor: SERVERNAME
Essa entrada do Registro, SERVERNAME representa o nome do servidor de catálogo global para que a tarefa de pesquisa de disponibilidade tenta vincular.

Observação Essa subchave do Registro difere na seguinte subchave do Registro. Você pode usar a seguinte subchave do Registro para configurar o componente DSAccess para usar apenas um diretório servidor ou servidor de um catálogo global:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\Exchange Provider\DS
Observação A subchave de registro de servidor de diretório pertence somente ao acesso ao diretório que envolve o componente DSAccess.

Após determinar o servidor de catálogo global para que a tarefa de pesquisa de disponibilidade tenta vincular, solucionar problemas de conectividade de rede geral. Dessa forma você pode certificar-se que o servidor de catálogo global é responder e se está funcionando corretamente.

Etapa 2: Verificar a relação de confiança entre domínios

Verifique se existe uma relação de confiança entre domínios a seguir:
  • O domínio no qual o Exchange Server está sendo executado
  • O domínio que contém o servidor de catálogo global para o qual as informações de disponibilidade tarefas de pesquisa tenta vincular
Por exemplo, você tem um ambiente de modo misto que possui o Exchange Server 5.5 executando em um domínio Windows NT 4.0. O problema pode ser causado por uma relação de confiança ausente entre o domínio de Windows NT 4.0 e o domínio que contém o servidor de catálogo global.

Por exemplo, você tiver um servidor que esteja executando o Exchange Server 5.5 e um segundo servidor que está executando o Exchange 2000 Server. Ou, o segundo servidor está executando o Exchange Server 2003. Para informações de disponibilidade compatibilidade existe entre esses dois servidores, a tarefa de pesquisa de disponibilidade deve representar a conta de serviço do Exchange Server 5.5. Não se houver nenhuma relação de confiança entre o domínio do Windows NT 4.0 e o domínio que contém o servidor de catálogo global, o Exchange Server gera eventos 8197. Isso ocorre quando a tarefa de pesquisa de disponibilidade tenta vincular para o servidor de catálogo global usando a conta de serviço do Exchange Server 5.5.

Esse cenário é mais provável de ocorrer quando um servidor de catálogo global está em um domínio raiz e Exchange Server está em um domínio filho no mesmo site de serviço de diretório do Active Directory. O mecanismo de referência do Windows ignora a participação no domínio quando o mecanismo tenta localizar um servidor de catálogo global. Considere o cenário de exemplo a seguir:
  • Um servidor de catálogo global está no domínio raiz de um site do Active Directory.
  • Um servidor de catálogo global está em um domínio filho do mesmo site do Active Directory.
  • Um servidor do Exchange está no domínio filho do mesmo site do Active Directory.
Nesse cenário, cada servidor de catálogo global tem a mesma chance de sendo usado pela tarefa de pesquisa de disponibilidade. No entanto, o servidor de catálogo global no domínio raiz da talvez não tenha uma relação de confiança com o domínio do Windows NT 4.0 que contém os servidores Exchange 5.5. Se não houver nenhuma relação de confiança, os seguintes sintomas podem ocorrer:
  • A tarefa de pesquisa de disponibilidade representa a conta de serviço do Exchange Server 5.5. Além disso, a tarefa tenta ligação ao servidor de catálogo global está no domínio raiz.
  • Porque não existe nenhuma relação de confiança entre o domínio raiz e o domínio do Windows NT 4.0 que contém a conta de serviço do Exchange Server 5.5, a autenticação é sem êxito.
Nessa situação, o Exchange Server gera eventos 8197.

Para contornar esse problema, execute estas etapas:
  1. Mova o servidor de catálogo global do domínio raiz para seu próprio site.
  2. Adicione sub-rede do servidor de catálogo global ao novo site.
  3. Dar algum tempo para que as alterações replicar entre os servidores que estejam na sua organização. Em seguida, reinicie o servidor de catálogo global que você moveu.
  4. Reinicie o servidor de catálogo global no domínio filho em que o Exchange Server está localizado.
  5. Reinicie o servidor Exchange.
  6. Exibir a entrada do registro que é descrita em "etapa 1: determinar o servidor de catálogo global para que a tarefa de pesquisa de disponibilidade tenta ligar." Fazer isso para verificar se a tarefa de pesquisa de disponibilidade usa o servidor de catálogo global do domínio filho que contém o servidor do Exchange. Talvez seja necessário aguardar até que os perfis criados antes de poder exibir essa entrada do Registro.
  7. Exiba o log Application para determinar se eventos 8197 continua a ser registrado.
Observação O mecanismo de referência Windows distingue somente servidores de catálogo global por associação do site e não por participação no domínio. Por exemplo, dois servidores de catálogo global podem ser de diferentes domínios. No entanto, se esses servidores de catálogo global no mesmo site, elas têm uma oportunidade igual que a tarefa de pesquisa de disponibilidade no site usará-los.

Etapa 3: Verificar se uma entrada de servidor de catálogo global incorreto está no Active Directory

Se o servidor de catálogo global específico que enfrenta esse problema está respondendo e parece funcionar corretamente, uma entrada de servidor de catálogo global incorreta pode estar localizada no Active Directory. Entradas de servidor incorreto de catálogo global também podem causar erros de evento 8197.

Para verificar se existem entradas incorretas, digite a seguinte consulta em um prompt de comando:
ldifde -f output.ldf -d "dc = mydomain, dc = com" -t - p 3268 subárvore-r"(&(objectclass=*)(name=SERVERNAME)) "
Neste comando, substitua os nomes correspondentes do seu domínio mydomain e com. Além disso, substitua SERVERNAME pelo nome do servidor de catálogo global para que a tarefa de pesquisa de disponibilidade tenta vincular. Depois de executar este comando, exibir o conteúdo do arquivo Output.ldf para determinar se existem entradas que se assemelhem à saída seguinte:
DN: CN = SERVERNAME, CN = computadores, DC = mysubdomain, DC = mydomain, DC = com

distinguishedName:
CN = SERVERNAME, CN = computadores, DC = na, DC = mydomain, DC = com
Nessa saída de exemplo, a entrada de servidor de catálogo global está incorreta. Essa entrada seguinte incorretamente aparece no recipiente computadores :
CN = computadores
Um servidor de catálogo global válido deve ter uma entrada no recipiente de Controladores de domínio . Isso é mostrado na saída de exemplo a seguir:
DN: CN = SERVERNAME, OU = controladores de domínio, DC = mydomain, DC = com

distinguishedName:
CN = SERVERNAME, OU = controladores de domínio, DC = mydomain, DC = com
Quando são exibidas duas entradas de servidor correto e incorreto no catálogo global no Active Directory, uma consulta DNS para um servidor de catálogo global pode retornar a entrada de servidor incorreto de catálogo global. Portanto, quando a tarefa de pesquisa de disponibilidade tenta ligação ao servidor de catálogo global, a tarefa é sem êxito.

Pode ser criada uma entrada de servidor de catálogo global incorreto se as seguintes condições forem verdadeiras:
  • Você configurar um servidor como um servidor membro em um domínio, como "subdomain. example.com."
  • Instalar o Active Directory neste servidor para alterar o status do servidor para que um controlador de domínio para um domínio diferente, como "example.com". Você, em seguida, configura este novo controlador de domínio como um servidor de catálogo global.
Para resolver esse problema, remova a entrada de servidor incorreto de catálogo global do Active Directory. Em seguida, libere o cache de resolvedor DNS no computador que está executando o Exchange Server. Para fazer isso, execute as seguintes etapas:
  1. Inicie o snap-in Active Directory Users and Computers . Para fazer isso, clique em Iniciar , clique em Executar , digite dsa.msc na caixa Abrir e, em seguida, clique em OK .
  2. Expanda o domínio e, em seguida, expanda o recipiente em que a entrada de servidor incorreto de catálogo global está localizada. Por exemplo, expanda computadores .
  3. Clique com o botão direito a entrada de servidor incorreto de catálogo global e, em seguida, clique em Excluir .
  4. Clique em Sim .
  5. Faça logon ao servidor do Exchange que está enfrentando esse problema e, em seguida, abra um prompt de comando.
  6. No prompt de comando, digite ipconfig /flushdns e pressione ENTER.

Método 4: Verificar se o Outlook está instalado no servidor do Exchange

É recomendável que você não instale o Outlook no mesmo computador que está executando o Exchange Server. Isso ocorre porque está em conflito pode ocorrer entre as versões de Exchange Server dos seguintes arquivos e as versões Outlook dos seguintes arquivos:
  • Mapi32.dll
  • Emsabp32.dll
  • Emsmdb32.dll
As Outlook as versões dos arquivos vêm de uma implementação MAPI que difere da implementação que é usada no Exchange Server. O Outlook possui requisitos diferentes de MAPI que Exchange Server. Implementação de MAPI de cada produto foi otimizada para atender aos requisitos do produto.

Por exemplo, o Exchange Server usa o arquivo Emsabp32.dll para passar credenciais, para autenticar e realizar uma operação Nspbind para o servidor de catálogo global para operações de pesquisa de endereço. O Outlook versão desse arquivo pede aos usuários suas credenciais quando ele executa essas operações. O Exchange Server versão desse arquivo usa um mecanismo diferente para passar as credenciais para a conta sistema local em que o Exchange Server é executado. Portanto, se você tiver o Outlook instalado em um computador que está executando o Exchange Server, você pode enfrentar erros de autenticação ou outra instabilidade no ambiente do Exchange Server.

Para resolver esse problema, remova o Outlook e, em seguida, reinstalar o Exchange Server.

Mais Informações

O componente Gerenciador de caixa de correio do Exchange também depende do mecanismo de referência do Windows para localizar um servidor de catálogo global. Geralmente, quando você enfrentar erros 8197 eventos que ocorrem com a tarefa de pesquisa de disponibilidade, o Gerenciador de caixa de correio também apresenta falhas. Nessa situação, os dois seguintes eventos são registrados no log do aplicativo:

Tipo de evento: erro
Origem do evento: MSExchangeSA
IDENTIFICAÇÃO de evento: 9175
Descrição: A chamada MAPI 'OpenMsgStore' falhou com o seguinte erro: não é possível abrir o armazenamento de informações. O logon para o computador com Microsoft Exchange Server falhou. Nº da identificação MAPI 1.0: 80040111-0286-00000000

Tipo de evento: erro
Origem do evento: MSExchangeSA
Categoria do evento: Gerenciamento de caixa de correio
IDENTIFICAÇÃO de evento: 9200
Descrição: Falha ao executar logon MAPI.

Propriedades

ID do artigo: 828764 - Última revisão: quinta-feira, 25 de outubro de 2007 - Revisão: 3.3
A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
Palavras-chave: 
kbmt kbeventlog kbtshoot kbclustering kbprb KB828764 KbMtpt
Tradução automática
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