Cannot Install Exchange Server 2003 in a Child Domain After You Run SETUP /DOMAINPREP

Article translations Article translations
Article ID: 817378 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

When you try to install Microsoft Exchange Server 2003 in your domain, you receive the following message:
Multiple components cannot be assigned the requested action(s) because:

- To install the first Exchange server in a domain, or to run setup in "/ForestPrep" mode, you must be an Exchange Full Administrator at the organization level. You must use an account that has been granted the Full Exchange Administrator role on the Exchange organization using the Exchange Administrative Delegation Wizard.

The component "Microsoft Exchange Messaging and Collaboration Services" cannot be assigned the action "Install" because:

- You either do not have permissions to complete this operation or Active Directory has not replicated all the necessary permissions for the deleted items container. Please check that you have the necessary permissions to modify Exchange components and that replication is complete before running setup.

- Setup cannot locate a qualifying Global Catalog server to connect to. Please run setup with the "/DomainPrep" switch in at least one domain that contains a Global Catalog server that belongs to the local or an adjacent Windows site.
You receive this message even if you already ran the setup /domainprep command in your domain and confirmed that you have the correct permissions.

CAUSE

This behavior may occur if all the following conditions are true:
  • You run the Exchange Server 2003 setup /forestprep command on a domain controller in a domain.
  • You run the Exchange Server 2003 setup /domainprep command on a domain controller in a child domain of that domain.
  • You run Setup to install Exchange Server 2003 on a server in that child domain.
This behavior occurs if there are no global catalog servers in the domain where you ran the setup /domainprep command, and you did not run setup /domainprep and configure a Recipient Update Service in the parent domain where the global catalog server resides. In this situation, the Exchange Server 2003 computer cannot contact the global catalog server.

WORKAROUND

To work around this behavior, set the System Access Control List permission for the domain where the global catalog server is located and then configure a Recipient Update Service for the domain. To do this, use one of the methods described in this section.

Note To complete this procedure, you must have the following rights:
  • Domain Administrator rights in the domain where the global catalog server is located
  • Local Administrator rights

Method 1: Run Setup /DomainPrep in the Parent Domain

Because the global catalog server resides in the parent domain of the domain where you want to install Exchange Server 2003, run setup /domainprep in the parent domain, and then create a Recipient Update Service for that domain. To do this, follow these steps:
  1. Log on to a domain controller in the parent domain.
  2. Run the Exchange Server 2003 setup /domainprep command in the parent domain.
  3. Start Exchange System Manager. If the Microsoft Exchange System Management Tools are not already installed, follow these steps:
    1. In the parent domain, log on to the server where you want to install Exchange System Manager.
    2. Start Setup.
    3. In the Action column, click Custom next to Microsoft Exchange.
    4. In the Action column, click Install next to Microsoft Exchange System Management Tools, and then click Next.
    5. When the Microsoft Exchange Installation Wizard completes the installation of the Microsoft Exchange System Management Tools, click Next, and then click Finish.
  4. Expand Recipients, right-click Recipient Update Services, point to New, and then click Recipient Update Service.
  5. Click Browse, click the parent domain in the Domains box, and then click OK.
  6. Click Next, and then click Browse to locate the Exchange server responsible for updating this domain.
  7. Click Advanced, click Find Now, click the server that you want to use to update the Recipient Update Service for the parent domain, and then click OK.
  8. Click OK, click Next, and then click Finish.
  9. Restart the Exchange server in the child domain, and then run Setup to install Exchange Server 2003.

Method 2: Configure a Global Catalog Server in the Child Domain

If you do not want to run setup /domainprep in the parent domain, configure a global catalog server in the child domain where you want to install Exchange Server 2003. To do this, follow these steps:
  1. Log on to a domain controller.
  2. Click Start, point to Administrative Tools, and then click Active Directory Sites and Services.
  3. Expand Sites, expand Default-First-Site-Name (where Default-First-Site-Name is the name of your site), expand Servers, and then expand a domain controller from the child domain where you want to install Exchange Server 2003.
  4. Right-click NTDS Settings, and then click Properties.
  5. Click to select the Global Catalog check box, and then click OK.
  6. Quit Active Directory Sites and Services.
  7. Run the Exchange Server setup /domainprep command again in the child domain.
  8. Restart the Exchange server, and then run Setup to install Exchange Server 2003.

Properties

Article ID: 817378 - Last Review: December 3, 2007 - Revision: 3.4
APPLIES TO
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Keywords: 
kbprb KB817378

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com