Applications that use the TDI driver for network traffic may stop responding in Windows Server 2008 or in Windows Vista

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Article ID: 2029048 - View products that this article applies to.
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SYMPTOMS

On a computer that is running Windows Server 2008 or Windows Vista, an application that uses transport driver interface (TDI) driver for network traffic may stop responding.

CAUSE

This issue occurs because of a race condition in the Tdx.sys driver. When a TCP SYN packet and a deactivation message for the address object are received at the same time, the Tdx.sys driver may detect that the address object is deactivated and does not process the packet. Additionally, the reference to the TCP listener is not cleaned. This behavior causes the threads to be blocked waiting for TCP. Therefore, the application stops responding.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 Service Pack 2 (SP2).

For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.0.600 0 . 20xxxWindows VistaRTMLDR
    6.0.600 1 . 22xxxWindows Vista and Windows Server 2008SP1LDR
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Tdx.sys6.0.6002.2240572,19214-May-201016:07x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Tdx.sys6.0.6002.2240594,72014-May-201016:26x64
For all supported IA-64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Tdx.sys6.0.6002.22405228,86414-May-201016:20IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This issue also affects Windows Server 2008 R2 and Windows 7. For more information about this issue in Windows Server 2008 R2 and Windows 7, click the following article number to view the article in the Microsoft Knowledge Base:

2028827 The applications that use the TDI driver for network traffic may stop responding in Windows Server 2008 R2 or in Windows 7
For more information about SYN packets, visit the following Microsoft website:
General information about SYN packets
For more information about TDI, visit the following Microsoft website:
Introduction to the transport driver interface
For more information about Windows 2000 network architecture, visit the following Microsoft website:
Overview of Windows 2000 network architecture
For more information about the Address object, visit the following Microsoft website:
Introduction to the "Address" object
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot Applicable
File size3,078
Date (UTC)18-May-2010
Time (UTC)04:34
PlatformNot Applicable
File nameX86_6abe0287f62cbe42a2f772d1e82c95a2_31bf3856ad364e35_6.0.6002.22405_none_a299ced555e3c670.manifest
File versionNot Applicable
File size702
Date (UTC)18-May-2010
Time (UTC)04:34
PlatformNot Applicable
File nameX86_microsoft-windows-tdi-over-tcpip_31bf3856ad364e35_6.0.6002.22405_none_ecb2e3d4f2550b42.manifest
File versionNot Applicable
File size4,590
Date (UTC)14-May-2010
Time (UTC)19:58
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
Collapse this tableExpand this table
File nameAmd64_4d868a0fbbceb67d8a5c1b85f27cf08b_31bf3856ad364e35_6.0.6002.22405_none_4efbb321abe57ca7.manifest
File versionNot Applicable
File size706
Date (UTC)18-May-2010
Time (UTC)04:34
PlatformNot Applicable
File nameAmd64_microsoft-windows-tdi-over-tcpip_31bf3856ad364e35_6.0.6002.22405_none_48d17f58aab27c78.manifest
File versionNot Applicable
File size4,854
Date (UTC)14-May-2010
Time (UTC)20:02
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size3,102
Date (UTC)18-May-2010
Time (UTC)04:34
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameIa64_85fe034963e85314e4ebebc9dfa2fec0_31bf3856ad364e35_6.0.6002.22405_none_04efcf3f7286c2e7.manifest
File versionNot Applicable
File size704
Date (UTC)18-May-2010
Time (UTC)04:34
PlatformNot Applicable
File nameIa64_microsoft-windows-tdi-over-tcpip_31bf3856ad364e35_6.0.6002.22405_none_ecb487caf253143e.manifest
File versionNot Applicable
File size4,849
Date (UTC)14-May-2010
Time (UTC)19:21
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,255
Date (UTC)18-May-2010
Time (UTC)04:34
PlatformNot Applicable

Properties

Article ID: 2029048 - Last Review: July 30, 2010 - Revision: 2.0
APPLIES TO
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
Keywords: 
kbsurveynew kbexpertiseadvanced kbhotfixserver kbautohotfix kbqfe kbfix KB2029048

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