XADM: Erro de falha de recursos em computadores com mais de 800 MB de RAM

Traduções deste artigo Traduções deste artigo
ID do artigo: 195006 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Sintomas

Em um computador Exchange Server muito ativo com mais de 800 megabytes (MB) de RAM, Exchange Server pode iniciar o log a seguinte mensagem de erro:
IDENTIFICAÇÃO de evento: 1160
Fonte: MSExchangeIS
Tipo: erro
Descrição: Erro de falha de recurso de banco de dados de memória ocorreu na função "JTAB_BASE::EcCreateIndex" ao acessar o banco de dados.
Observação : os itens colocados entre aspas duplas podem ser diferentes caso a caso.

Causa

Esse problema ocorre porque o Exchange Server tenta alocar mais memória virtual que está disponível dentro do processo.

O espaço de endereço de memória virtual do Microsoft Windows NT é 4 gigabytes (GB) para cada processo. Isso implica que não importa o quanto de memória física instalada, um único processo tem acesso a apenas 4 GB de espaço de endereço. Além disso, o Windows NT divide a memória virtual em memória que é usada pelo kernel e a memória que seja acessível para modo de usuário (para o aplicativo). No Windows NT Server 4.0 ou Windows 2000 Server padrão, um aplicativo de modo de usuário (como Store.exe) tem acesso a 2 GB de memória virtual e o núcleo usa os 2 GB. No Windows NT 4.0 Enterprise Edition e Windows 2000 Server, um aplicativo de modo de usuário tem acesso a 3 GB de memória virtual e o kernel obtém 1 GB.

Todas as alocações de memória para um processo vêm fora dos 2 ou 3 GB disponível no espaço de endereço. O espaço de endereço não é vazio quando um processo for carregado; muitos elementos ocupam espaço no-lo imediatamente. O próprio código é carregado na memória virtual (Store.exe e todas as DLLs); uma pilha de sistema é alocada de memória virtual; para cada thread criado, uma alocação de memória virtual de 1 MB (normalmente) é criada para a pilha de thread e assim por diante.

O resultado é que para um processo individual, o processo não será capaz de alocar um completo 2 ou 3 GB de memória virtual porque alguns a memória está em uso.

O Assistente para Exchange Server 5.5 desempenho (Perfwiz) faz cálculos sobre quanta memória virtual será ser usada, usando a quantidade de RAM física como um indicador. Quando 2 GB de RAM é fisicamente instalado, Perfwiz assumirá que ele pode alocar até 2 GB de memória virtual para um processo. Essa quantidade de memória virtual não pode ser livre no espaço de endereço de um processo, para que tentar alocar esta quantidade de memória virtual pode falhar.

Resolução

Para resolver esse problema, obtenha o service pack mais recente para o Exchange Server versão 5.5. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
191014XGEN: Como obter o Service Pack mais recente do Exchange Server 5.5
A versão em inglês dessa correção deve ter os seguintes atributos de arquivo ou posteriores:

Componente: Programa de administrador

Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão
Perfwiz.exe5.5.2527.0

Depois de adicionar o arquivo Perfwiz.exe atualizado para o computador com Exchange Server, você precisa executar novamente o otimizador de desempenho para reajustar suas configurações de memória para o armazenamento de informações para resolver os erros 1160.

Situação

A Microsoft confirmou que este é um problema no Microsoft Exchange Server versão 5.5. Esse problema foi corrigido primeiro no Exchange Server 5.5 Service Pack 3.

Propriedades

ID do artigo: 195006 - Última revisão: quinta-feira, 10 de outubro de 2013 - Revisão: 4.2
A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 5.5 Standard Edition
Palavras-chave: 
kbnosurvey kbarchive kbmt kbbug kbfix kbqfe KB195006 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 195006
Obtenha mais suporte em smallbusiness.support.microsoft.com

Entre em contato conosco para obter mais ajuda

Entre em contato conosco para obter mais ajuda
Conecte-se com o Answer Desk para obter ajuda especializada.